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The Windows based set-up program is menu driven, allowing the user 
to easily view data, alter set-up variables or set color control 
parameters using a PC running the Windows 
(95/98/ME/2000/XP/NT) operating system. The set-up variables are 
used to configure and tune the M4503 to match the configuration and 
performance of the specific printer (see section 2.7 - HSM-Ductor 
Set-up). 
 
Note:  The set-up program is an on-line communications program 
used to interface with the M4503 module.  The data displayed and set 
in the windows is communicated directly to the module, while in the 
“Online” edit mode. Therefore, prior to going online with the 
processor, make sure an RS-232 cable is connected from the COM 
port on the computer to the "PROG" port on the M4503.  The 
variables displayed while in the “Online” edit mode are read directly 
from the processor.  Data is saved to a “Set-up Data” file (*.sdt) 
whenever changes are made to a parameter or if the data is uploaded 
from the processor. 
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________________________________________________________ 
4.1 GENERAL DESCRIPTION 
 
Title Bar:  At the top of the window is the “Title Bar”.  The title bar 
is used to display the name of the working “Set-up Data” file, as well 
as, the name of the active “Window”.  The title bar is dark if the 
window is active and grayed if another window is active.  The color 
depends on the settings of the Display Properties of the Control Panel. 
 
Status Bar:  At the bottom of the window is the “Status Bar”.  The 
status bar is used to display system messages, online or offline mode, 
as well as, the current time and date as set by the operating system.  
The system messages panel displays general information about 
operation of the system.  The Online/Offline mode panel displays the 
status of the current set-up program mode of operation.  The mode of 
operation can be changed by simply double clicking the online/offline 
mode panel. 
 
Hot Keys:  Hot keys are activated by holding down the “ALT” key 
and simultaneously pressing the underlined letter of the desired 
function.  Almost every function can be activated by either pressing a 
series of hot keys or using the “TAB” key to move between fields. 
 
Online/Offline Modes:  The set-up program allows the user to 
make changes while “Online” with the processor.  The “Offline” 
mode is used to preset parameters prior to download.  All functions 
are available to the user while “Online”, however, specific “Online” 
functions are disabled in the “Offline” edit mode. 
 
Note:  Offline changes can only be made by enabling “Offline 
Editing”, accessed under the “Edit” menu. 
 
Getting Help:  The entire user’s manual is contained within the help 
file.  Pressing Ctrl+H will display the help file window.  Pressing the 
F1 key will display the contents file.  Hot spots allow jumps to other 
topics to display additional information as desired.  Selecting About 
RTFCD7 from the Help menu will display a dialog box listing 
information about the current revision of the setup program and how 
to obtain technical support. 
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________________________________________________________ 
4.2 THE FILE MENU 
 
The “File” menu allows the user to perform the following functions: 
 
• Create a “New” set-up “Data File”. 
• Open an existing “Data File”. 
• Save any changes made to the current “Data File” to disk. 
• Upload (save) Data from the Processor. 
• Download a SYSdev (.sdv) program to the processor 
• Download (restore) Data from the current set-up “Data File” to 

the processor 
• Print a Report of the current set-up parameters. 
• Exit the set-up program 
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________________________________________________________ 
4.2.1 THE SET-UP DATA FILE 
 
The set-up “Data File” (.sdt) is a binary access file, designed for fast 
file I/O operation.  When the set-up program is first invoked, the 
default set-up parameters are loaded into memory.  If changes are 
made to any of the set-up parameters (either online or offline), as well 
as shift data, the user will be flagged to “Save Changes” upon exit of 
the program. 
 
Note:  Any windows based “Set-up” program can open a set-up 
“Data File”, however, the data tables will not be properly aligned.  
The user will be alerted to the problem if a set-up data file has been 
created by either a different set-up program or a different revision of 
the software. 
 
The set-up “Data File” is similar to that of a word processing file.  
When the program is first started, the default parameters are loaded 
and the user is able to make any changes as desired.  The set-up 
program is unaware of the settings and parameters that exist within 
the M4503.  Therefore, to normalize the set-up program with the 
processor, the user should define or open an existing file, then upload 
“All” variables from the processor.  This allows the user to either 
create a backup of the data or maintain an existing file.  The user can 
even open a data file for another printer, save the file to a new name, 
make the necessary changes and simply download the new parameters 
to another processor. 
 
The following functions can be accessed any time, from any set-up or 
display windows. 
 
New:  To create a “New” data file, select “New” from the “File” 
menu or press “Ctrl + N”.  This creates a completely new file, loaded 
with the default variables and the word “[unnamed]” is displayed in 
the title bar.  If any changes were made to the existing file, the user is 
prompted to save changes to the existing file. 
 
Open:  To “Open” and existing data file, select “Open” from the 
“File” menu or press “Ctrl + O”.  This displays a dialog box allowing 
the user to select an existing data file to open. The name of the file 
will be displayed in the title bar.  If any changes were made to the 
existing file, the user will be prompted to save any changes before 
terminating the program. 
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Save:  To “Save” data file to disk, select “Save” from the “File” 
menu or press “Ctrl + S”.  This displays a dialog box allowing the 
user to select a folder and enter a name for the file.  The user will be 
notified if the file already exists and the extension “.sdt” will 
automatically be added to the file name.  If this is a “New” file, the 
user will be prompted to enter a file name. 
 
Save As:  To save the data file to a new name, select “Save As” 
from the “File” menu..  This displays a dialog box allowing the user 
to select a folder and enter in a new name for the file.  The user will 
be notified if the file exists and the extension “.sdt” will automatically 
be added to the file name. 
 
Export Shift Data…:  This function allows the user to export the 
shift data to a “Tab Delimited” text file.  This allows the user to easily 
use the shift data to produce production reports. 
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________________________________________________________ 
4.2.2 UPLOAD (SAVE) DATA 
 
The “Set-up” program allows the user to upload set-up parameters, 
color control settings and shift data from the M4503 into a set-up 
“Data File”.  This function is accessed from the “File” menu and the 
user is given the choice of the following options: 
 

 
 
Set-up Data:  This option uploads the ductor cycling parameters 
data from the M4503.   
 
Shift Data:  This option uploads the “Shift Data” from the M4503.  
This is the individual cycling counts for each ductor. 
 
Label Data:  This option uploads the “Label Data” from the M4503.  
This is the ON duration and CYCLE duration settings for each label.  
The user will be prompted to select a range of labels to upload or 
select “All” (default). This allows the user to upload the label 
information from one processor and download it to another, without 
altering any of the other set-up parameters or shift data registers. 
 
All:  This option allows the user to completely upload “All” of the 
set-up parameters, shift data and label data from the M4503. 
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________________________________________________________ 
4.2.3 DOWNLOAD PROGRAM 
 
The “Set-up” program allows the user to “Download” any SYSdev 
program file to the M4503. 
 

 
 
Note:  To “Download” a SYSdev program to the processor, the 
program must be “Online”.  If “Online” mode cannot be achieved, 
program download will not be executed.  If the program is currently 
“Offline”, the user will be prompted to first go “Online”. 
 
Once selected, and the set-up program “Online” with the processor, a 
dialog box will be displayed, allowing the user to select the SYSdev 
file to download. 
 
Note:  Only the files with the “.sdv” file extension will be displayed.  
It is important to keep in mind that only a valid M4503 PLC SYSdev 
file can be downloaded through the set-up program.  Care should be 
taken when selecting a program to download. 
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Once selected, a message box is displayed informing the user of the 
current program, revision and checksum of the program loaded in the 
processor, as well as, that of the selected program.  The user must 
confirm their selection by clicking the “Yes” command button.  After 
the user confirms their choice, program download is initiated and the 
current program download address is displayed.  When program 
download is complete, the user is prompted to acknowledge.  Control 
is passed back to the main program and the set-up program remains in 
an “Online” edit mode. 
 
 
________________________________________________________ 
4.2.4 DOWNLOAD (RESTORE) DATA 
 
The set-up program allows the user to download  “Set-up” data, shift 
data and Label data to the M4503 from the set-up “Data File”.  This 
function is accessed from the “File” menu and the user is given the 
choice of the following options: 
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Set-up Data:  This option downloads the ductor cycling parameters 
data from the M4503.   
 
Shift Data:  This option downloads the “Shift Data” from the 
M4503.  This is the individual cycling counts for each ductor. 
 
Label Data:  This option downloads the “Label Data” from the 
M4503.  This is the ON duration and CYCLE duration settings for 
each label.  The user will be prompted to select a range of labels to 
download or select “All” (default). This allows the user to upload the 
label information from one processor and download it to another, 
without altering any of the other set-up parameters or shift data 
registers. 
 
All:  This option allows the user to completely upload “All” of the 
set-up parameters, shift data and label data from the M4503. 
 
Note:  Only the values contained within the current data file are used.  
If the validity of the current data file is questionable, review the data 
in an “Offline” mode prior to download. 
 
 
________________________________________________________ 
4.2.5 PRINT REPORT 
 
The “Set-up” program allows the user to generate a “Report” printout 
of all the set-up parameters, label data and shift data.  This function is 
accessed from the “File” menu. 
 
Prior to selecting “Print Report…”, the user should select “Report 
Setup” to set the following report printout options. 
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At the top of each page, the report displays the name of the set-up file 
being printed.  At the bottom of each page is the date and time the 
document was printed, as well as, the page number. 
 
To printout a report of the settings contained in the set-up “Data File”, 
perform the following: 
 
1) From the “File” menu, select “Print Report” or press “Ctrl + P”.  

This displays the “Print Setup” dialog box, allowing the user to 
select a printer, as well as, the paper size and orientation.  Once 
the user selects “OK”, the report is generated and sent to the 
specified printer device.  This function makes use of the windows 
print manager, which allows the user to continue with their work 
while the document is being printed. 

 
 
________________________________________________________ 
4.3 THE EDIT MENU 
 
The “Edit” menu allows the user to perform the following functions: 
 
• Enable/Disable Offline Editing 
• Set-up the Comm Port 
• Edit the Color Control Passcode 
 

 



SECTION 4 
HSMDUCTOR WINDOWS BASED 
SETUP PROGRAM REFERENCE 

 
HSM-DUCTOR User’s Manual SYSTEMS Electronics Group 

 
- 37 - 

________________________________________________________ 
4.3.1 ENABLE OFFLINE EDITING 
 
This function allows the user to perform “Offline” editing on the 
currently loaded set-up data file.  This allows the user the ability to 
make any necessary changes to the set-up parameters while not online 
with the processor.   
 
If offline editing is not enabled, the user is only able to view the set-
up parameters and shift data.  When the program is first invoked, the 
default setting is offline editing disabled.  The user will need to 
specifically select “Enable Offline Editing” from the edit menu (or 
press function key F2) to enable/disable this feature. 
 
 
________________________________________________________ 
4.3.2 SETUP COMM PORT 
 
This function allows the user to specify the serial communications 
port and baud rate to talk to the M4503.  The programming port of the 
M4503 is set to 9600 baud.   
 
Once selected, a dialog box requesting the user to select a “Comm 
Port” and “Baud Rate” will be displayed. 
 

 
 
The default setting is COM1 at 9600 baud.  The option to select the 
19200 baud rate is to allow the user to communicate with the 
processor via the S4516 serial communications board. 
 
The user will only need to specify the communications port and leave 
the baud rate at 9600.  If communication problems occur, make sure 
there is a secure connection from the PC to the PLC.  Then check the 
Comm port.  In most cases, the user will only need to select a new 
Comm port.  If communication problems persist, there may be 
another program causing a conflict with the port.  Check the port 
configuration from the “Settings” folder. 
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________________________________________________________ 
4.3.3 EDIT COLOR CONTROL PASSCODE 
 
The edit “Color Control Passcode” is an “Online” function only.  This 
allows the user the ability to directly change the value of the “Color 
Control Passcode”. 
 
Once selected, an input box is displayed, allowing the user to view 
the current “Passcode” setting and to change the value if necessary.   
 

 
 
If the passcode is set to zero, passcode entry is disabled.  The operator 
would then press the Color Control key on the Keypad/Display and 
then press the <ENTER> key to gain access to the color control 
settings without having to enter a zero.  
 
If the value of the “Color Control Passcode” is set somewhere 
between 1 and 65,000, “Passcode Entry” is enabled.  This requires the 
operator to enter in the “Correct” passcode to gain access to the color 
control parameters. 
 
Note:  Passcode entry is only in effect when the “Set-up Enable” 
selector switch is in the “Disable” position. 
 
If an invalid value is entered, the passcode value will not be reset and 
a message box notifying the user of the error is displayed.  
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________________________________________________________ 
4.4 THE VIEW MENU 
 
The “View” menu allows the user to perform the following functions: 
 
• View the “Target Board Interface” 
• View “Online” Data 
• View “Offline” Data 
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________________________________________________________ 
4.4.1 TARGET BOARD INTERFACE 
 
This function allows the user to view fault codes, S3000 network 
communication error codes and review the current “Ident” and 
“Revision” of the application program.  This is accessed by the 
“View” menu, by selecting “Target Board Interface”. 
 

 
 
Once invoked, the set-up program will prompt the user to select a 
program to compare with the one existing in the processor.  Whether 
a program is selected or the user cancels, the setup program will 
attempt to communicate with the M4503.  If unsuccessful, a warning 
message will be displayed, prompting the user to either “Retry” or 
“Cancel” the operation.  If the operation is canceled and 
communication with the processor cannot be established the system 
will be placed in an “Offline” mode, however the “Target Board 
Interface” window will be displayed. 
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________________________________________________________ 
4.4.2 VIEW ONLINE DATA 
 
This function allows the user to place the set-up program in an 
“Online” mode with the processor.  This is accessed by the “View” 
menu, by selecting “Online Data” or by simply pressing the “F3” 
function key. 
 
Note:  The program can be toggled between “Offline” and “Online” 
by simply double clicking on the “Online” or “Offline” panel 
displayed in the status bar at the bottom of the window. 
 
Once invoked, the set-up program will attempt to open the Comm 
port and communicate with the M4503.  If the set-up program is 
unsuccessful, a warning message will be displayed prompting the user 
to either “Retry” or “Cancel” the operation.  If the operation is 
canceled and communication with the processor cannot be established 
the system will be placed in an “Offline” edit mode. 
 
Note:  Anytime while the set-up program is “Online” with the 
processor and communication is interrupted, a warning message will 
be displayed, prompting the user to either “Retry” or “Cancel” the 
operation. 
 
 
________________________________________________________ 
4.4.3 VIEW OFFLINE DATA 
 
This function allows the user to place the set-up program in an 
“Offline” mode.  This is accessed by the “View” menu, by selecting 
“Offline Data” or by simply pressing the “F4” function key.  This 
allows the user to perform “Offline” editing.  All values displayed in 
“Offline” edit mode reflect the actual values contained in the 
currently loaded set-up data file. 
 
Note:  The program can be toggled between “Online” and “Offline” 
by simply double clicking on the “Online” or “Offline” panel 
displayed in the status bar at the bottom of the window. 
 
Once invoked, the set-up program will close the Comm port and cease 
communication with the M4503. 
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________________________________________________________ 
4.5 THE WINDOW MENU 
 
The “Window” menu allows the user to select one of six different 
Display/Set-up windows to modify set-up parameters, view shift data 
or receive feedback about the current status of the control system. 
 

 
 
Once a window menu item is selected, a check mark is placed next to 
the selected item and the selected window is displayed with the name 
changed in the title bar of the main window. 
 
Note:  “Read” only variables are displayed in blue with a gray 
background.  Any variables that can be altered by the user are 
displayed in black with a white background.  In most cases, a 
parameter that can be changed by the user will have associated with it 
increment and decrement controls.  The user can either click on the 
desired parameter to adjust and enter in a new value, or use the 
increment or decrement controls to change the value by 1 unit. 
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________________________________________________________ 
4.5.1 THE MAIN DISPLAY WINDOW 
 
The “Main Display” window is used to display the general state of the 
control system.  This window is selected from the “Window”. 
 

 
 
The following is a list of the functions of the “Main Display” 
window. 
 
Messages:  The “Messages” display is continuously updated.  It 
displays alarm and status messages specific to the M4503, as well as, 
the current “Online” or “Offline” status of the set-up program.  By 
simply scrolling the display, the user is able to view all active alarm 
and status messages.  If no alarm or status messages are active, a 
default message is displayed. 
 
Machine CPM:  This display is only active while “Online” and 
displays the current speed of the machine in “Cans Per Minute”. 
 
Alarm Reset:  This function is only available “On-Line”. 
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________________________________________________________ 
4.5.2 THE SETUP PARAMETERS WINDOW 
 
The “Set-up Parameters” window is used to view and adjust any of 
the set-up parameters.  This window is selected from the “Window” 
menu. 
 

 
 
Cycling Parameters:  This is used to set the ductor solenoid 
control parameters in the M4503.  This section contains the following 
selections: 
 
1) Maximum Cycle Duration (0.1 cans):  The maximum cycle 

duration is the maximum cycle time (in 0.1 cans) for one cycle of 
the ductor.  This parameter limits the upper value that the operator 
can enter for the cycle duration.  If the operator attempts to enter a 
value higher then this limit, the value will default back to the 
original number.  The range of this parameter is 140 - 999. 

 
2) Maximum ON Duration (0.1 cans):  This parameter limits the 

upper value that the operator can enter for the “ON” duration.  
The cycle duration is the total cycle time (in 0.1 cans) that the 
ductor roll is in contact with the fountain roll.  If the operator 
attempts to enter a number higher than the maximum “ON” 
duration, the value will default back to the previous value.  The 
range of this parameter is 0 – 200. 
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3) Response Time Compensation (msec):  This parameter is 
the difference (in msec) between the “ON” and “off” response 
times of the ductor solenoid.  This is used to adjust the “ON” 
duration to compensate for the mechanical response time of the 
whole mechanism.  As an example, if the “ON” response time was 
40 msec. and the “off” response time was 15 msec.  Then the 
value entered for this parameter would be 25 msec. 

 
Note:  If the optional feedback sensors are used, set this 
parameter to 0.  The feedback sensors will automatically adjust 
the “ON” duration based on the response time of the solenoids. 

 
4) Color Gain:  This parameter allows the color density to be 

increased proportionately up or down as a function of machine 
speed.  The valid range of this parameter is 50% to 150% per 
2000 CPM.  When set to 100%, no increase or decrease, as a 
function of speed will occur.  When set to 50%, the color density 
will drop 50% from 0 to 2000CPM.  When set to 150% the color 
density will increase by 50% from 0 to 2000CPM.  This parameter 
is used to compensate for ink atomization (misting) as a function 
of speed (higher speed = proportionately higher ink misting). 

 
5) Enable/Disable Ductor Feedback Fault:  This selection is 

used to enable or disable the feedback fault detection.  When the 
optional feedback sensors are installed, the ductor feedback faults 
should be enabled.  The feedback sensor verifies the cycling of the 
ductor and resets the “ON” duration as the speed of the machine 
changes based on the response time of the solenoid.  
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________________________________________________________ 
4.5.3 THE SHIFT DATA WINDOW 
 
The “Shift Data” window is used to view the shift data collected by 
the M4503.  This window is selected from the “Window” menu. 
 

 
 
Cycle Counts: This displays the total number of cycles for each 
ductor.   
 
Reset Counts: Pressing this key allows the total cycle counts for 
each ductor to be reset.  The user can also choose to reset an 
individual ductor by setting or incrementing the “Ductor Number” 
and then pressing the Reset Counts command button. 
 
 



SECTION 4 
HSMDUCTOR WINDOWS BASED 
SETUP PROGRAM REFERENCE 

 
HSM-DUCTOR User’s Manual SYSTEMS Electronics Group 

 
- 47 - 

________________________________________________________ 
4.5.4 THE COLOR CONTROL WINDOW 
 
The “Color Control” window is used to view and adjust any of the 
color control settings.  This window is selected from the “Window” 
menu. 
 

 
 
 
Color Control Parameters:  The label number, “On” duration and 
“Cycle” duration are used to adjust the color control settings in the 
M4503.   
 
The following is a description of each of these settings: 
 
1) Label Number:  The M4503 is capable of storing the settings 

for up to 100 labels (0-99).  Select desired label number to adjust 
the “On” and “Cycle” duration settings. 

 
 Note:  The user can only adjust the “Label Number” when the 

machine is at “Zero Speed” (main drive off and no motion 
detected). 
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2) On Duration:  The “On” duration can be individually set for 
each ink station, for each label.  The “On” duration is the amount 
of time (cans) the ductor roll is in contact with the fountain roll.  
Follow the procedure outlined in section 3.5 – Light/Dark Color 
Adjustment of Ink Station, to properly adjust the “On” duration. 

 
 Note:  The user cannot adjust the “On” duration to within 14 cans 

(140 tenths) of the “Cycle” duration.  To disable a ductor from 
cycling, set this variable to zero. 

 
3) Cycle Duration:  The “Cycle” duration can be individually set 

for each ink station, for each label.  The “Cycle” duration is the 
frequency at which the ductor is activated.  This is the duration 
(number of cans) between one complete cycle.  Follow the 
procedure outlined in section 3.5 – Light/Dark Color Adjustment 
of Ink Station, to properly adjust the “Cycle” duration. 

 
 Note:  The user cannot adjust the “Cycle” duration to within 14 

cans (140 tenths) of the “On” duration. 
 
4) Color Density:  The “Color Density” display is used as an 

indication of the amount of ink being transferred by the ductor.  
Different settings of the “On” and “Cycle” durations will achieve 
the same “Color Density”.  Follow the procedure outlined in 
section 3.2 – Recommended Procedure for using the color control. 
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Solenoid Response Time:  The “Solenoid Response” time is an 
indication of the reaction time of pneumatic ductor.  The response 
times are only valid when the optional feedback sensors are used.  
The response times for each ink station can be easily viewed by 
adjusting the station number.   
 
The following is a description of each of these settings: 
 
1) Station Number:  The ink station mask to view the response 

time of the ductor solenoid. 
 
2) Solenoid “On” Response Time (msec):  This displays the 

amount of time (msec) from first activation of the solenoid to 
contact with the fountain roll. 

 
3) Solenoid “Off” Response Time (msec):  This displays the  

amount of time (msec) from first deactivation of the ductor 
solenoid to lift-off from fountain roll. 

 
 
Ductor Status:  The ductor “Status” gives the user an indication of 
the status of the input signals used to control the pneumatic ductor, 
these are as follows: 
 
1) Operational Mode:  A three-position selector switch is used to 

set the operation mode of the ductors (auto/off/manual).  This 
display reflects the position of the selector switch. 

 
2) Ductors Auto On:  This displays the state of the ductors “Auto 

On” input to the M4503 
 
 
Ductors Manual Control:  This allows the user to toggle 
individual ductor solenoids when the ductors operational mode is 
“Manual” and the machine is at “Zero” speed (main drive off, 
machine not in motion).  The individual solenoids can be toggled 
“On” and “Off” by clicking on the individual stations.  The user may 
also toggle “All” the ink stations “On” by clicking the “Ductors ON 
All” command or toggle all “Off” by clicking the “Ductors OFF All” 
command button. 
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________________________________________________________ 
4.5.5 THE I/O STATES WINDOW 
 
The “I/O States” window is provided to display states of the inputs 
and outputs.  The control boards, as well as states of the M4503 are 
shown.  This includes the interrupt inputs (IN0 and IN1), the analog 
I/O and the resolver.  These values are displayed as read by the 
M4503 processor. 
 

 
 
 
 
 


