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The Windows based set-up program is menu driven, allowing the user 
to easily view data, alter set-up variables or set machine timing 
(machine offset, timing signal locations, etc.), using a PC running the 
Windows (95/98/ME/2000/XP/NT) operating system. The set-up 
variables are used to configure and tune the M4503 to match the 
configuration and performance of the specific decorator (see Tuning 
the HSM-CD7, section 2.11). 
 
Note:  The set-up program is an on-line communications program 
used to interface with the M4503 module.  The data displayed and set 
in the windows is communicated directly to the module, while in the 
“Online” edit mode. Therefore, prior to going online with the 
processor, make sure an RS-232 cable is connected from the COM 
port on the computer to the "PROG" port on the M4503.  The 
variables displayed while in the “Online” edit mode are read directly 
from the processor.  Data is saved to a “Set-up Data” file (*.sdt) 
whenever changes are made to a parameter or if the data is uploaded 
from the processor. 
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________________________________________________________ 
4.1 GENERAL DESCRIPTION 
 
Title Bar:  At the top of the window is the “Title Bar”.  The title bar 
is used to display the name of the working “Set-up Data” file, as well 
as, the name of the active “Window”.  The title bar is dark if the 
window is active and grayed if another window is active.  The color 
depends on the settings of the Display Properties of the Control Panel. 
 
Status Bar:  At the bottom of the window is the “Status Bar”.  The 
status bar is used to display system messages, online or offline mode, 
as well as, the current time and date as set by the operating system.  
The system messages panel displays general information about 
operation of the system.  The Online/Offline mode panel displays the 
status of the current set-up program mode of operation.  The mode of 
operation can be changed by simply double clicking the online/offline 
mode panel. 
 
Hot Keys:  Hot keys are activated by holding down the “ALT” key 
and simultaneously pressing the underlined letter of the desired 
function.  Almost every function can be activated by either pressing a 
series of hot keys or using the “TAB” key to move between fields. 
 
Online/Offline Modes:  The set-up program allows the user to 
make changes while “Online” with the processor.  The “Offline” 
mode is used to preset parameters prior to download.  All functions 
are available to the user while “Online”, however, specific “Online” 
functions are disabled in the “Offline” edit mode. 
 
Note:  Offline changes can only be made by enabling “Offline 
Editing”, accessed under the “Edit” menu. 
 
Getting Help:  The entire contents of the user’s manual is contained 
within the help file.  Pressing Ctrl+H will display the help file 
window.  Pressing the F1 key will display the contents file.  Hot spots 
allow jumps to other topics to display additional information as 
desired.  Selecting About RTFCD7 from the Help menu will display a 
dialog box listing information about the current revision of the setup 
program and how to obtain technical support. 
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________________________________________________________ 
4.2 THE FILE MENU 
 
The “File” menu allows the user to perform the following functions: 
 
• Create a “New” set-up “Data File”. 
• Open an existing “Data File”. 
• Save any changes made to the current “Data File” to disk. 
• Upload (save) Data from the Processor. 
• Download a SYSdev (.sdv) program to the processor 
• Download (restore) Data from the current set-up “Data File” to 

the processor 
• Print a Report of the current set-up parameters. 
• Exit the set-up program 
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________________________________________________________ 
4.2.1 THE SET-UP DATA FILE 
 
The set-up “Data File” (.sdt) is a binary access file, designed for fast 
file I/O operation.  When the set-up program is first invoked, the 
default set-up parameters are loaded into memory.  If changes are 
made to any of the set-up parameters (either online or offline), as well 
as shift data, the user will be flagged to “Save Changes” upon exit of 
the program. 
 
Note:  Any windows based “Set-up” program can open a set-up 
“Data File”, however, the data tables will not be properly aligned.  
The user will be alerted to the problem if a set-up data file has been 
created by either a different set-up program or a different revision of 
the software. 
 
The set-up “Data File” is similar to that of a word processing file.  
When the program first starts a default file is loaded and the user is 
able to make any changes as desired.  The set-up program is unaware 
of the settings and parameters that exist within the M4503.  
Therefore, to normalize the set-up program with the processor, the 
user should define or open an existing file, then upload “All” 
variables from the processor.  This allows the user to either create a 
backup of the data or maintain an existing file.  The user can even 
open a data file for another decorator, save the file to a new name, 
make the necessary changes and simply download the new parameters 
to another processor. 
 
The following functions can be accessed any time, from any set-up or 
display windows. 
 
New:  To create a “New” data file, select “New” from the “File” 
menu or press “Ctrl + N”.  This creates a completely new file, loaded 
with the default variables and the word “[unnamed]” is displayed in 
the title bar.  If any changes were made to the existing file, the user is 
prompted to save changes to the existing file. 
 
Open:  To “Open” and existing data file, select “Open” from the 
“File” menu or press “Ctrl + O”.  This displays a dialog box allowing 
the user to select an existing data file to open. The name of the file 
will be displayed in the title bar.  If any changes were made to the 
existing file, the user will be prompted to save any changes before 
terminating the program. 
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Save:  To “Save” data file to disk, select “Save” from the “File” 
menu or press “Ctrl + S”.  This displays a dialog box allowing the 
user to select a folder and enter a name for the file.  The user will be 
notified if the file already exists and the extension “.sdt” will 
automatically be added to the file name.  If this is a “New” file, the 
user will be prompted to enter a file name. 
 
Save As:  To save the data file to a new name, select “Save As” 
from the “File” menu..  This displays a dialog box allowing the user 
to select a folder and enter in a new name for the file.  The user will 
be notified if the file exists and the extension “.sdt” will automatically 
be added to the file name. 
 
Export Shift Data…:  This function allows the user to export the 
shift data to a “Tab Delimited” text file.  This allows the user to easily 
use the shift data to produce production reports. 
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________________________________________________________ 
4.2.2 UPLOAD (SAVE) DATA 
 
The “Set-up” program allows the user to upload blow-off parameters, 
timing channel set-points and shift data from the M4503 into a set-up 
“Data File”.  This function is accessed from the “File” menu and the 
user is given the choice of the following options: 
 

 
 
Set-up Parameters:  This option uploads the “Set-up” data from 
the M4503.  This includes the print carriage and varnish unit response 
times, as well as, blow-off parameters. 
 
Timing Channels:  This option uploads the “Machine Timing” 
channel set-points, as well as, the PLS configuration and scale factor. 
 
Shift Data:  This option uploads the “Shift Data” from the M4503.  
This includes the “Trips per Spindle” data, the “Current Shift” and the 
“Last Shift” data. 
 
All:  This option allows the user to completely upload “All” of the 
set-up parameters, timing channel set-points and shift data from the 
M4503. 
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________________________________________________________ 
4.2.3 DOWNLOAD PROGRAM 
 
The “Set-up” program allows the user to “Download” any SYSdev 
program file to the M4503. 
 

 
 
Note:  To “Download” a SYSdev program to the processor, the 
program must be “Online”.  If “Online” mode cannot be achieved, 
program download will not be executed.  If the program is currently 
“Offline”, the user will be prompted to first go “Online”. 
 
Once selected, and the set-up program “Online” with the processor, a 
dialog box will be displayed, allowing the user to select the SYSdev 
file to download. 
 
Note:  Only the files with the “.sdv” file extension will be displayed.  
It is important to keep in mind that only a valid M4500 PLC SYSdev 
file can be downloaded through the set-up program.  Care should be 
taken when selecting a program to download. 
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Once selected, a message box is displayed informing the user of the 
current program, revision and checksum of the program loaded in the 
processor, as well as, that of the selected program.  The user must 
confirm their selection by clicking the “Yes” command button.  After 
the user confirms their choice, program download is initiated and the 
current program download address is displayed.  When program 
download is complete, the user is prompted to acknowledge.  Control 
is passed back to the main program and the set-up program remains in 
an “Online” edit mode. 
 
 
________________________________________________________ 
4.2.4 DOWNLOAD (RESTORE) DATA 
 
The set-up program allows the user to download  “Set-up” 
parameters, timing channel set-points and shift data to the M4503 
from the set-up “Data File”.  This function is accessed from the “File” 
menu and the user is given the choice of the following options: 
 

 
 
Set-up Parameters:  This option downloads the “Set-up” data to 
the M4503.  This includes print carriage and varnish unit response 
times and blow-off parameters. 
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Timing Channels:  This option downloads the “Machine Timing” 
channel set-points, as well as the PLS configuration and scale factor 
to the M4503 PLS. 
 
Shift Data:  This option downloads the “Shift Data” to the M4503.  
This includes the “Trips per Spindle” data, the “Current Shift” and the 
“Last Shift” data. 
 
All:  This option allows the user to completely download “All” of the 
set-up parameters, timing channel set-points and shift data to the 
M4503. 
 
Note:  Only the values contained within the current data file are used.  
If the validity of the current data file is questionable, review the data 
in an “Offline” mode prior to download. 
 
 
________________________________________________________ 
4.2.5 PRINT REPORT 
 
The “Set-up” program allows the user to generate a “Report” printout 
of all the set-up parameters, timing channel set-points and shift data.  
This function is accessed from the “File” menu. 
 
At the top of each page, the report displays the name of the set-up file 
being printed.  At the bottom of each page is the date and time the 
document was printed, as well as, the page number. 
 
To printout a report of the settings contained in the set-up “Data File”, 
perform the following: 
 
1) From the “File” menu, select “Print Report” or press “Ctrl + P”.  

This displays the “Print Setup” dialog box, allowing the user to 
select a printer, as well as, the paper size and orientation.  Once 
the user selects “OK”, the report is generated and sent to the 
specified printer device.  This function makes use of the windows 
print manager, which allows the user to continue with their work 
while the document is being printed. 
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________________________________________________________ 
4.3 THE EDIT MENU 
 
The “Edit” menu allows the user to perform the following functions: 
 
• Enable/Disable Offline Editing. 
• Set-up the Comm Port. 
 

 
 
 
________________________________________________________ 
4.3.1 ENABLE OFFLINE EDITING 
 
This function allows the user to perform “Offline” editing on the 
currently loaded set-up data file.  This allows the user the ability to 
make any necessary changes to the set-up parameters while not online 
with the processor.   
 
If offline editing is not enabled, the user is only able to view the set-
up parameters and shift data.  When the program is first invoked, the 
default setting is offline editing disabled.  The user will need to 
specifically select “Enable Offline Editing” from the edit menu (or 
press function key F2) to enable/disable this feature. 
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________________________________________________________ 
4.3.2 SETUP COMM PORT 
 
This function allows the user to specify the serial communications 
port and rate to talk to the M4503.  The programming port of the 
M4503 is set to 9600 baud.   
 

 
 
Once selected, a dialog box requesting the user to select a “Comm 
Port” and “Baud Rate” will be displayed.  The default setting is 
COM1 at 9600 baud.  The option to select the 19200 baud rate is to 
allow the user to communicate with the processor via the S4516 serial 
communications board. 
 
In most cases the user will only need to specify the communications 
port and leave the baud rate at 9600.  If communication problems 
occur, make sure there is a secure connection from the PC to the PLC.  
Then check the Comm port.  In most cases the user will only need to 
select a new Comm port.  If communication problems persist there 
may be another program causing a conflict with the port.  Check the 
port configuration from the “Settings” folder. 
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________________________________________________________ 
4.4 THE VIEW MENU 
 
The “View” menu allows the user to perform the following functions: 
 
• View the “Target Board Interface” 
• View “Online” Data 
• View “Offline” Data 
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________________________________________________________ 
4.4.1 TARGET BOARD INTERFACE 
 
This function allows the user to view fault codes, S3000 network 
communication error codes and review the current “Ident” and 
“Revision” of the application program.  This is accessed by the 
“View” menu, by selecting “Target Board Interface”. 
 

 
 
Once invoked, the set-up program will prompt the user to select a 
program to compare with the one existing in the processor.  Whether 
a program is selected or the user cancels, the setup program will 
attempt to communicate with the M4503.  If unsuccessful a warning 
message will be displayed, prompting the user to either “Retry” or 
“Cancel” the operation.  If the operation is canceled and 
communication with the processor cannot be established the system 
will be placed in an “Offline” mode, however the “Target Board 
Interface” window will be displayed. 
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________________________________________________________ 
4.4.2 VIEW ONLINE DATA 
 
This function allows the user to place the set-up program in an 
“Online” mode with the processor.  This is accessed by the “View” 
menu, by selecting “Online Data” or by simply pressing the “F3” 
function key. 
 
Note:  The program can be toggled between “Offline” and “Online” 
by simply double clicking on the “Online” or “Offline” panel 
displayed in the status bar at the bottom of the window. 
 
Once invoked, the set-up program will attempt to open the Comm 
port and communicate with the M4503.  If the set-up program is 
unsuccessful, a warning message will be displayed prompting the user 
to either “Retry” or “Cancel” the operation.  If the operation is 
canceled and communication with the processor cannot be established 
the system will be placed in an “Offline” edit mode. 
 
Note:  Anytime while the set-up program is “Online” with the 
processor and communication is interrupted, a warning message will 
be displayed, prompting the user to either “Retry” or “Cancel” the 
operation. 
 
 
________________________________________________________ 
4.4.3 VIEW OFFLINE DATA 
 
This function allows the user to place the set-up program in an 
“Offline” mode.  This is accessed by the “View” menu, by selecting 
“Offline Data” or by simply pressing the “F4” function key.  This 
allows the user to perform “Offline” editing.  All values displayed in 
“Offline” edit mode reflect the actual values contained in the 
currently loaded set-up data file. 
 
Note:  The program can be toggled between “Online” and “Offline” 
by simply double clicking on the “Online” or “Offline” panel 
displayed in the status bar at the bottom of the window. 
 
Once invoked, the set-up program will close the Comm port and cease 
communication with the M4503. 
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________________________________________________________ 
4.5 THE WINDOW MENU 
 
The “Window” menu allows the user to select one of six different 
Display/Set-up windows to modify set-up parameters, view shift data 
or receive feedback about the current status of the control system. 
 

 
 
Once a window menu item is selected, a check mark is placed next to 
the selected item and the selected window is displayed and the name 
is changed in the title bar of the main window. 
 
Note:  “Read” only variables are displayed in blue with a gray 
background.  Any variables that can be altered by the user are 
displayed in black with a white background.  In most cases, a 
parameter that can be changed by the user will have associated with it 
increment and decrement controls.  The user can either click on the 
desired parameter to adjust and enter in a new value, or use the 
increment or decrement controls to change the value by 1 unit. 
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________________________________________________________ 
4.5.1 THE MAIN DISPLAY WINDOW 
 
The “Main Display” window is used to display the general state of the 
control system.  This window is selected from the “Window” menu. 
 

 
 
The following is a list of the functions of the “Main Display” 
window. 
 
Messages:  The “Messages” display is continuously updated.  It 
displays alarm and status messages specific to the M4503, as well as, 
the current “Online” or “Offline” status of the set-up program.  By 
simply scrolling the display, the user is able to view all active alarm 
and status messages.  If no alarm or status messages are active, a 
default message is displayed. 
 
Machine CPM:  This display is only active while “Online” and 
displays the current speed of the machine in “Cans Per Minute”. 
 
Good Cans:  This display is the “Current Shift” good can count.   
 
Blow-offs:  This display is the “Current Shift” total blow-off count. 
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Q.C. Blow-off:  This display is only active while “Online” and it 
allows the operator to perform a “QC Select-A-Can” blow-off.   
The operator can perform a “Single” blow-off by entering in the 
desired spindle number and clicking the “Single Blow-off” command 
button.  
• The operator can perform a “Blanket” blow-off by clicking the 

“Blanket Blow-off” command button.  The blanket blow-off will 
initiate a blow-off sequence such that a can printed by each 
blanket is blown off at the QC blow-off port, starting with a can 
printed by blanket #1. 

• The operator can perform a “Mandrel” Blow-off by clicking the 
“Mandrel Blow-off” command button.  The mandrel blow-off will 
initiate a blow-off sequence such that a can printed on each 
mandrel will be consecutively blown off at the QC blow-off port, 
starting with mandrel #1. 

 
Bad Can Blow-off:  This display is only active while “Online” and 
it allows the operator to test the action of the control system by 
electronically inducing a mis-loaded or “Bad Can” into the system.  
By clicking on the Test Trip/Blow-off command button, a “Bad Can” 
will be electronically induced into the system to test the response of 
the control system due to a “Mis-Loaded” can. 
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________________________________________________________ 
4.5.2 THE SETUP PARAMETERS WINDOW 
 
The “Set-up Parameters” window is used to view and adjust any of 
the set-up parameters.  This window is selected from the “Window” 
menu. 
 

 
 
This window utilizes a “TAB” control to divide the set-up parameters 
into three categories, similar to that of the Keypad/Display. 
 
Print Carriage/Varnish Unit:  This section is used to set the print 
carriage “Retract/Extend” response times and the varnish unit 
“Retract/Extend” response times in the M4503.  This section contains 
the following selections: 
 
1) Print Carriage Retract (out) Response Time (msec): This 

is the time used as the retract response time of the carriage unit 
(time from solenoid actuation to first break with blanket) in 
milliseconds. This will activate the retract solenoid this amount of 
time ahead of the Carriage unit trip timing (CH00) (usually set at 
40 to 50 milliseconds). 
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2) Print Carriage Extend (in) Response Time (msec): This is 
the time used as the extend response time of the carriage unit 
(time from solenoid actuation to first contact with blanket) in 
milliseconds. This will activate the extend solenoid this amount of 
time ahead of the Carriage unit trip timing (CH00) (usually set at 
40 to 50 milliseconds). 

 
3) Varnish Unit Retract (out) Response Time (msec): This is 

the time used as the retract response time of the varnish unit (time 
from solenoid actuation to first break with varnish wheel) in 
milliseconds. This will activate the extend solenoid this amount of 
time ahead of the Varnish unit trip timing (CH01) (usually set at 
60 milliseconds). 

 
4) Varnish Unit Extend (in) Response Time (msec): This is 

the time used as the extend response time of the varnish unit (time 
from solenoid actuation to first contact with varnish wheel) in 
milliseconds. This will activate the extend solenoid this amount of 
time ahead of the Varnish unit trip timing (CH01) (usually set at 
60 milliseconds). 

 
5) Number of Shifts to Varnish Unit: This is the number of 

spindles from the Can Sensor to the varnish unit minus 2. In 
general this is set such that the varnish unit retracts out on the can 
ahead of the misloaded spindle. For older generation Rutherford 
Decorators this is set to "5". For newer decorators, this is set to 
"4". 
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Blow-off Parameters:  This section is used to set the “Pin 
Chain/QC Blow-off” parameters in the M4503. 
 

 
 
Note:  The “Bad Can Blow-off” command button will electronically 
induce a mis-loaded can into the system, as well as, the “Q.C. Can 
Blow-off” will blow-off a can printed on spindle #1 at the QC blow-
off port. 
 
1) Number of Pins to Pin Chain Blow-off Port:  This is the 

number of pins from the spindle wheel to disk transfer location to 
the first can blown off at the Pin Chain blow-off port minus two.  
This can be a number from 0 to 999. 

 
2) Number of Cans from Infeed to Can PRX:  This parameter 

is used to adjust the number of stations from the can gate solenoid 
to can/no can sensor.  Default value is set to 6 stations.  Some 
Rutherford decorators utilize an infeed star wheel, adding an 
additional 6 (total 12) stations from infeed to can PRX. 

 
3) Number of Cans to Blow-off for Each Mis-load: This is the 

number of cans blown off at the pin chain port when one mis-
loaded can is detected (typically set at 1 can). 
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4) Number of Cans to Blow-off at Infeed Open: This is the 
number of cans which will be blown off when the infeed is first 
opened.  To blow off no cans at infeed open, set equal to 0, to 
blow off one can set equal to 1, etc. 

 
5) Number of Cans to Blow-off from Print at Restart: This is 

the number of cans which will be blown off from the print station 
when the machine is restarted.  To blow off no cans at restart, set 
equal to 0, to blow off one can set equal to 1, etc. 

 
6) Number of Cans to Blow-off from Varnish at Restart: 

This is the number of cans which will be blown off from the 
varnish station when the machine is restarted.  To blow off no 
cans at restart, set equal to 0, to blow off one can set equal to 1, 
etc. 

 
7) Q.C. Can Blow-off Port Shift Offset: This is the number of 

spindles difference from detection of the spindle #1 flag to the QC 
blow-off port.  This is a number between 1 and 24 and is 
empirically set by selecting spindle #1 for blow-off and adjusting 
this value until the can from spindle #1 is the can that is blown 
off. 

 
8) Number of Segments on Blanket Wheel: The blanket wheel 

segments is the value used to blow-off a consecutive number of 
cans (starting with blanket #1) whenever a “Blanket” QC Blow-
off is initiated (QC blow-off code #25). 
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Blow-off Solenoids:  This section is used to adjust the response 
times of the “Bad Can” and “QC” blow-off solenoid in the M4503. 
 

 
 
 
1) Bad Can Blow-off Solenoid “ON” Response Time: This is 

the time used as the "on" response time of the pin chain blow-off 
port (time from "on" solenoid actuation to first air out port) in 
milliseconds.  The M4503 will activate the solenoid “ON” this 
amount of time ahead of the Pin Chain blow-off “ON” position 
(usually set at 15 to 20 milliseconds). 

 
2) Bad Can Blow-off Solenoid “Off” Response Time: This is 

the time used as the "off" response time of the pin chain blow-off 
port (time from "off" solenoid actuation to air stopping at port) in 
milliseconds.  The M4503 will activate the solenoid “OFF” this 
amount of time ahead of the Pin Chain blow-off “ON” position 
(usually set at 15 to 20 milliseconds for double acting solenoids 
and set at 25 to 30 milliseconds for single acting solenoids). 

 
3) Q.C Can Blow-off Solenoid “ON” Response Time: This is 

the time used as the "on" response time of the QC blow-off port 
(time from "on" solenoid actuation to first air out port) in 
milliseconds.  The M4503 will activate the solenoid “ON” this 
amount of time ahead of the QC blow-off timing “ON” position 
(usually set at 15 to 20 milliseconds). 
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4) Q.C. Can Blow-off Solenoid “Off” Response Time: This is 
the time used as the "off" response time of the QC blow-off port 
(time from "off" solenoid actuation to air stopping at port) in 
milliseconds.  The M4503 will activate the solenoid “OFF” this 
amount of time ahead of the QC blow-off timing “ON” position 
(usually set at 15 to 20 milliseconds for double acting solenoids 
and set at 25 to 30 milliseconds for single acting solenoids).  

 
 
________________________________________________________ 
4.5.3 THE SERIAL COMMUNICATIONS WINDOW 
 
The Serial Communications window is used to view the configuration 
status of the S4516 serial communications board (if installed), as well 
as, view the status of the Allen-Bradley DF1 communication protocol 
and set-up the Allen-Bradley PLC communication parameters.  From 
this window the user can view or adjust the following parameters: 
 
• View the S4516 configuration status. 
• View the S4516-DF1 serial communication status. 
• View the Allen-Bradley Link Layer serial communication status. 
• Select the Allen-Bradley PLC type (PLC5 or SLC500) to 

communicate to. 
• View/Set the Allen-Bradley PLC destination node. 
• Select the starting Allen-Bradley PLC destination file number. 
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S4516 Configuration Status:  This displays the current state of 
the configuration of the S4516 serial communications board.  System 
function sfunc19(); (S4516 configuration) is used to set the S4516 
configuration (network node address, network baud rate and USER 
port baud rate).  This must be executed prior to executing ether 
system functions 10, 11 or 13.  System function 19 is generally 
executed in the “Initialization” file of the user program. 
 
The following values are returned from a system function 19 call: 
 1 = Busy. 
 2 = Done (S4516 Successfully configured). 
 3 = Invalid Parameter (either network node address, network 

baud rate or USER port baud rate is invalid). 
 4 = Timeout (no response form S4516) 
 32 = Hardware ACK error from S4516 
 34 = Invalid S4516 Slot Address (W8156 must be loaded with 

the slot address of the S4516, prior to executing system 
function 19). 

 
Transmit Data Status:  This represents the state of the data packet 
transmission and will typically display either “Busy” or “Done”.  If 
there are problems delivering the message packet, the response code, 
along with a description, will be displayed. 
 
Note:  The “Transmit Data Status (prev.)” is used to view the last or 
previous status. 
 
Current Transaction:  This is the “Transaction” number delivered 
to the Allen-Bradley PLC. 
 
Active Command:  This displays either “Read” or “Write”.  This is 
used to view the command type of the current transaction. 
 
Number of  BYTES Received:  This displays the current number 
of bytes received from either a “Command” or “Reply” message 
packet. 
 
Received Command BIT Status:  This displays the state of the 
command received.  If this displays a “Reply”, then the command was 
sent from the M4503.  If this displays “Command”, then a command 
action was received by the M4503. 
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A/B Link Layer Status:  This displays the status of the receipt of 
the message packet sent to the Allen-Bradley PLC.  If the delivery is 
not successful, an error code along with a description is displayed.  
Refer the to the Allen-Bradley Communication Protocol and 
Command Set reference manual for more information on “Link 
Layer” error codes. 
 
A/B Link Layer – Current Transaction Received:  This is the 
“Transaction” number received from the Allen-Bradley PLC. 
 
PLC Type:  This is used to specify the “Type” of PLC the M4503 
will communicate to.  The user can choose from “PLC5” or 
“SLC500”. 
 
Note:  This parameter should be set prior to communicating with an 
A/B processor. 
 
Destination Node:  This is used to set the node number of the A/B 
PLC to send and receive data from.  This also displays the node 
number of the A/B PLC that send a “Command” message packet. 
 
Destination File Number:  This is the file number the M4503 will 
read and write data from.  See Appendix B for a description of the 
data read from and written to an Allen-Bradley PLC. 
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________________________________________________________ 
4.5.4 THE MACHINE TIMING WINDOW 
 
The Machine Timing window is used to invoke the PLS programming 
command menus.  From this window, the user can view or adjust the 
following parameters: 
 
• Adjust Timing Channel setpoints. 
• Set the Main Crank resolver offset. 
• Clear or Recall a PLS timing channel. 
• View the current PLS configuration 
• Reset the PLS configuration to default settings. 
 

 
 
In addition, the following parameters are displayed at the bottom of 
this window: 
 
RPM:  This is the current speed in “Revolutions per Minute” of the 
main crank resolver. 
 
Position:  This is the current “Position” in degrees of the main crank 
resolver. 
 
Offset:  This is the current resolver offset (set in degrees). 
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Scale:  This is the scale factor of the resolver or the number of 
divisions in one revolution. 
 
Note:  The General Timing Signal Locations section provides a 
complete description of each timing channel signal. 
 
 
Zeroing the Machine (setting the resolver offset):  To set 
machine zero, perform the following: 
 
1) Connect an RS-232 SYSdev cable from the COM port on the 

computer to the “PROG” port on the M4503.   
 
2) From the “Window” menu, select “Machine Timing”. 
 
3) From the “View” menu, select “Online Data”.  The set-up 

program will attempt to communicate with the processor and 
place the system into an “Online” mode of operation. 

 
4) Observe the “Position” field at the bottom of the window.  Verify 

that as the machine is rotated forward, that the position increases 
linearly from 0 through 359 degrees.  If not, swap the S1 and S3 
leads at the resolver connector on the M4503.  Then, verify that 
the position does indeed increase with forward movement. 

 
5) Position the machine at machine zero (spindle aligned with V 

notch at top backside of machine frame, see section 2.11.2 - Set 
Machine Zero). 

 
6) Auto zero the resolver by entering “0” in the “Resolver Offset” 

field and clicking the “Set Offset” command button.  A message 
box will appear, prompting the user to confirm their choice.  
Select “Yes” to set the resolver offset. 

 
7) The M4503 will calculate the actual offset value required to make 

this the “0” position.  The new offset value will be displayed in 
the “Offset” field and the position will then read zero. 
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Adjusting the Timing Channel Setpoints:  To set any of the 
timing signal setpoints, perform the following: 
 
Note:  Any changes made to the timing channel setpoints will be 
saved as part of the setup data file. 
 
1) Connect an RS-232 SYSdev cable from the COM port on the 

computer to the “PROG” port on the M4510.   
 
2) From the “Window” menu, select “Machine Timing”. 
 
3) From the “View” menu, select “Online Data”.  The set-up 

program will attempt to communicate with the processor and 
place the system into an “Online” mode of operation. 

 
4) Set all channels per the section 6 – General Timing Signal 

Locations.  Set-points for a particular channel are either entered in 
the field or adjusted by using the increment/decrement controls. 

 
Note:  Only one set-point is used per channel.  

 
5) If a channel needs to be “Recalled” or “Cleared”, enter the desired 

channel number into the “PLS Channel” field.  Click the “Recall 
Channel” command button to recall the setpoints.  Click the 
“Clear Channel” command button the completely clear all 
setpoints for the selected channel. 

  
 Note:  If a channel has been cleared or the “On” and “Off” 

setpoints have the same setting, the set-point will be displayed as 
“*****”. 
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Resetting the PLS Configuration:  As an aid to the user the 
current PLS configuration is displayed in the “PLS Configuration” tab 
of this window.  The PLS configuration should only be reset if a new 
module has been installed.  To reset the PLS configuration, click the 
“Reset PLS Config” command button.  This function only resets the 
PLS configuration to the default settings. 
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________________________________________________________ 
4.5.5 THE SHIFT DATA WINDOW 
 
The “Shift Data” window is used to view the shift data collected by 
the M4503.  This window is selected from the “Window” menu. 
 

 
 
This window utilizes a “TAB” control to divide the set-up parameters 
into three categories, similar to that of the Keypad/Display.  These 
sections are as follows: 
 
Trips per Spindle: The Number of trips per spindle display is 
provided to aid in the trouble-shooting of a loading problem with a 
spindle or spindles.  The total number of trips for each spindle since 
the last reset or end of shift is displayed.  The operator can reset these 
counts at anytime to aid in the trouble-shooting process.   
 
The following data is displayed in the "Trips per Spindle" section: 
 
1) Spindle #1 Trip Offset:  The "Spindle Trip Offset" can be 

entered from this section.  This is used to compensate for the 
location of the can/no can sensor and the spindle #1 I.D. sensor 
location.  Use the “Tripped Spindle” display to adjust the offset 
value.  Follow the procedure outlined in section 2.11.11 – Set 
Spindle Trip Shift Offset. 

 



SECTION 4 
RTFCD7 WINDOWS BASED 

SETUP PROGRAM REFERENCE 

 
HSM-CD7 User’s Manual SYSTEMS Electronics Group 

 
- 77 - 

2) Spindle #xx Trips: This is the total number of trips for each 
spindle. This data is displayed and updated continuously in the 
respective field for each spindle.  A disproportionately high count 
for a particular spindle indicates a loading problem for that 
spindle. 

 
Current Shift Data:  This section is used to view the “Current 
Shift” data.  This data is the totals so far into the shift.  This data is 
transferred to the "Last shift" at the end of either an 8 or 12 hour shift 
or alternatively could be done at label changes such that the data 
collected would be for label runs rather than complete shifts.  This 
data can be reset by the user from this section. 
 

 
 
Note:  The “Transfer Data” command button is only active while 
“Online”.   
 
1) Total Good Cans: This is the total number of good cans printed 

so far into the shift.  This is essentially a can counter. 
 
2) Total Blow-offs: This is the total number of cans blown-off the 

machine.  This includes all types of blow-offs: the can(s) blown-
off for each mis-load, infeed open blow-offs, restart blow-offs, 
manual blow-offs, select-a-can QC blow-offs, etc. 
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3) Total Bad Cans or Mis-loads: This is the total number of mis-
loaded cans (trips). These would be the actual number of damaged 
cans that did not load properly on the machine.  This gives an 
indication of conveying/can handling problems. 

 
4) Manual Blow-offs: This is the total number of cans blown-off 

by the operator using the Manual Blow-off PB or selector switch. 
 
5) QC Blow-offs: This is the total number of cans blown-off by the 

operator with the Select-A-Can QC station or QC Blow-off key on 
the M4503 keypad for quality verification. 

 
6) Restart Blow-offs: This is the total number of cans blown off 

when the infeed opened and from the print station and varnish 
station at machine restart. 

 
7) Total Trips: This is the total number of trips (sum of the 

individual trips per spindle) for the shift. 
 
8) Spindle #01 through #24: This is the total trips (mis-loads) for 

each spindle.  A disproportionately high count for a particular 
spindle indicates a loading problem for that spindle. 
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Last Shift Data:  The "Last Shift" data is identical to the current 
shift data except it is for the previous 8 or 12 hour shift or previous 
label run, however the shift collection is set-up.  This allows data 
collection and diagnostics to take place automatically over a two shift 
period. 
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________________________________________________________ 
4.5.6 THE I/O STATES WINDOW 
 
The “I/O States” window is provided to display states of the inputs 
and outputs.  The control boards, the states of the timing channels, as 
well as states of the M4503 are shown.  This includes the interrupt 
inputs (IN0 and IN1), the analog I/O and the resolver.  These values 
are displayed as read by the M4503 processor. 
 

 
 
 
 


