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The set-up program is a Windows based menu driven program, 
allowing the user to easily view data, alter set-up variables or set 
machine timing (machine offset, timing signal locations, etc.), using a 
PC running the Windows™ (95/98/ME/2000/XP) operating system. 
The set-up variables are used to configure and tune the M4500 to 
match the configuration and performance of the specific bodymaker 
(see section 2.7 – HSLW-WI5 Set-Up). 
 
Note:  The set-up program is an on-line communications program 
used to interface with the.  The data displayed and set in the windows 
is communicated directly to the module, while in the “Online” edit 
mode. Therefore, prior to going online with the processor, make sure 
an RS-232 cable is connected from the COM port on the computer to 
the “PROG” of the M4500.  The variables displayed while in the 
“Online” edit mode are read directly from the processor.  Data is 
saved to a “Set-up Data” file (*.sdt) whenever changes are made to a 
parameter or when data is uploaded from the processor. 
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________________________________________________________ 
4.1 GENERAL DESCRIPTION 
 
Title Bar:  At the top of the window is the “Title Bar”.  The title bar 
is used to display the name of the working “Set-up Data” file, as well 
as, the name of the active “Window”.  The title bar is dark if the 
window is active and grayed if another window is active.  The color 
depends on the settings of the Display Properties of the Control Panel. 
 
Status Bar:  At the bottom of the window is the “Status Bar”. The 
status bar is used to display system messages, online or offline mode, 
as well as, the current time and date as set by the operating system.  
The system messages panel displays general information about 
operation of the system.  The Online/Offline mode panel displays the 
status of the current set-up program mode of operation.  The mode of 
operation can be changed by simply double clicking the online/offline 
mode panel. 
 
Hot Keys:  Hot keys are activated by holding down the “ALT” key 
and simultaneously pressing the underlined letter of the desired 
function.  Almost every function can be activated by either pressing a 
series of hot keys or using the “TAB” key to move between fields. 
 
Online/Offline Modes:  The set-up program allows the user to 
make changes while “Online” with the processor.  The “Offline” 
mode is used to preset parameters prior to download.  All functions 
are available to the user while “Online”, however, specific “Online” 
functions are disabled in the “Offline” edit mode. 
 
Note:  Offline changes can only be made by enabling “Offline 
Editing”, accessed from the “Edit” menu. 
 
Getting Help:  The entire contents of the user’s manual is contained 
within the help file.  Pressing Ctrl+H will display the help file 
window.  Pressing the F1 key will display the contents file.  Hot spots 
allow jumps to other topics to display additional information as 
desired.  Selecting “About HSLWI5” from the Help menu will display 
a dialog box listing information about the current revision of the setup 
program and how to obtain technical support. 
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________________________________________________________ 
4.2 THE FILE MENU 
 
The “File” menu allows the user to perform the following functions: 
 
• Create a “New” set-up “Data File”. 
• Open an existing “Data File”. 
• Save any changes made to the current “Data File” to disk. 
• Upload (save) Data from the M4500. 
• Download a SYSdev (.sdv) program to the M4500. 
• Download (restore) Data to the M4500. 
• Print a Report of the current set-up parameters. 
• Exit the set-up program 
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________________________________________________________ 
4.2.1 THE SETUP DATA FILE 
 
The set-up “Data File” (.sdt) is a binary access file, designed for fast 
file I/O operation.  When the set-up program is first invoked, the 
default set-up parameters are loaded into memory.  If changes are 
made to any of the set-up parameters (either online or offline), as well 
as shift data, the user will be flagged to “Save Changes” upon exit of 
the program. 
 
Note:  Any windows based “Set-up” program can open a set-up 
“Data File”, however, the data tables will not be properly aligned. If a 
set-up data file was created by either a different set-up program or a 
different revision of software, the user will be alerted to the problem. 
 
The set-up “Data File” is similar to that of a word processing file.  
When the program first starts a default set of values is loaded and the 
user is able to make any changes as desired.  The set-up program is 
unaware of the parameters that exist within the M4500.  Therefore, to 
normalize the set-up program with the processor, the user should 
define or open an existing file, then upload (save) data from the 
processor.  This allows the user to either create a backup of the data 
or maintain an existing file.  The user can even open a data file for 
another machine, save the file to a new name, make the necessary 
changes and simply download the new parameters to another 
processor. 
 
The following functions can be accessed any time, from any set-up or 
display windows. 
 
New:  To create a “New” data file, select “New” from the “File” 
menu or press “Ctrl + N”.  This creates a completely new file, loaded 
with the default variables and the word “[unnamed]” is displayed in 
the title bar.  If any changes were made to the existing file, the user is 
prompted to save changes prior to exit. 
 
Open:  To “Open” and existing data file, select “Open” from the 
“File” menu or press “Ctrl + O”.  This displays a dialog box, which 
allows the user to navigate and select an existing data file to open and 
the name of the file will be displayed in the title bar.  If any changes 
were made to the existing file, the user will be prompted to save any 
changes first. 
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Save:  To “Save” data file to disk, select “Save” from the “File” 
menu or press “Ctrl + S”.  This displays a dialog box, which allows 
the user to select a folder and enter in a name for the file.  The user 
will be notified if the file name already exists and the extension “.sdt” 
will automatically be added to the file name.  If this is a “New” file, 
the user will be prompted to enter a file name. 
 
Save As:  To save the data file to a new name, select “Save As” 
from the “File” menu..  This displays a dialog box, which allows the 
user to select a folder and enter in a new name for the file.  The user 
will be notified if the file name already exists and the extension “.sdt” 
will automatically be added to the file name. 
 
Export Shift Data…:  This function allows the user to export the 
shift data to a “Tab Delimited” text file.  This allows the user to easily 
use the shift data to produce production reports. 
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________________________________________________________ 
4.2.2 UPLOAD (SAVE) DATA 
 
The “Set-up” program allows the user to upload set-up parameters, 
timing channel set-points and shift data from the M4500 to a set-up 
“Data File”.  This function is accessed from the “File”. 
 
 
________________________________________________________ 
4.2.3 DOWNLOAD PROGRAM 
 
The “Set-up” program allows the user to “Download” any SYSdev 
program file to the M4500. 
 
Note:  To “Download” a SYSdev program to the processor, the 
program must be “Online”.  If “Online” mode cannot be achieved, 
program download will not be executed.  If the program is currently 
“Offline”, the user will be prompted to first go “Online”. 
 
Once selected, and the set-up program “Online” with the processor, a 
dialog box will be displayed, allowing the user to select the SYSdev 
file to download. 
 
Note:  Only the files with the “.sdv” file extension will be displayed.  
It is important to keep in mind that only a valid M4500 PLC SYSdev 
file can be downloaded. Care should be taken when selecting the 
program to download. 
 
Once selected, a message box is displayed informing the user of the 
current program, revision and checksum of the program loaded in the 
processor, as well as, that of the selected program.   
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The user must confirm their selection by clicking the “Yes” command 
button.  After the user confirms their choice, program download is 
initiated and the current program download address is displayed.  
When program download is complete, the user is prompted to 
acknowledge.  Control is passed back to the main program and the 
set-up program remains in an “Online” edit mode. 
 
________________________________________________________ 
4.2.4 DOWNLOAD (RESTORE) DATA 
 
The set-up program allows the user to download  “Set-up” 
parameters, timing channel set-points and shift data to the M4500 
from the set-up “Data File”.  This function is accessed from the “File” 
menu. 
 
Note:  Only the values contained within the current data file are used.  
If the validity of the current data file is questionable, review the data 
in an “Offline” mode prior to download. 
 
________________________________________________________ 
4.2.5 PRINT REPORT 
 
The “Set-up” program allows the user to generate a “Report” printout 
of all the set-up parameters, timing channel set-points and shift data 
(of the current set-up file).  This function is accessed from the “File” 
menu. At the top of each page, the report displays the name of the set-
up file, at the bottom of each page is the date and time the printout 
was generated, as well as the page number. 
 
To printout a report of the settings contained in the set-up “Data File”, 
perform the following: 
 
1) From the “File” menu, select “Print Report” or press “Ctrl + P”.   
 
2) The “Print Setup” dialog box will then be displayed, allowing the 

user to select a printer, as well as, the paper size and orientation.  
Once the user selects “OK”, the report is generated and sent to the 
specified printer device.   

 
Note: This function makes use of the windows print manager, which 
allows the user to continue with their work while the document is 
being printed. 
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________________________________________________________ 
4.3 THE EDIT MENU 
 
The “Edit” menu allows the user to perform the following functions: 
 
• Enable/Disable Offline Editing. 
• Set-up the Comm Port. 
 

 
 
 
________________________________________________________ 
4.3.1 ENABLE OFFLINE EDITING 
 
This function allows the user to perform “Offline” editing on the 
currently loaded set-up data file, making any necessary changes to 
set-up parameters or timing channels while not online with the 
processor.   
 
If offline editing is not enabled, the user is only able to view the set-
up and shift data.  When the program is first invoked, the default 
setting is “Offline Editing” - disabled.  The user will need to select 
“Enable Offline Editing” from the edit menu (or press function key 
F2) to enable or disable this feature. 
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________________________________________________________ 
4.3.2 SETUP COMM PORT 
 
This function allows the user to specify the serial communications 
port and rate to talk to the M4500.  The programming port of the 
M4500 is set to 9600 baud.   
 

 
 
Once selected, a dialog box requesting the user to select a “Comm 
Port” and “Baud Rate” will be displayed.  The default setting is 
COM1 at 9600 baud.  
 
In most cases the user will only need to specify the communications 
port and leave the baud rate at 9600.  If communication problems 
occur, make sure there is a secure connection from the PC to the PLC.  
Then check the Comm port.  In most cases the user will only need to 
select a new Comm port.  If communication problems persist, there 
may be another program causing a conflict with the port.  Check the 
port configuration from the “Settings” folder. 
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________________________________________________________ 
4.4 THE VIEW MENU 
 
The “View” menu allows the user to perform the following functions: 
 
• View the “Target Board Interface” 
• View “Online” Data 
• View “Offline” Data 
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________________________________________________________ 
4.4.1 TARGET BOARD INTERFACE 
 
This function allows the user to view fault codes, S3000 network 
communication error codes and review the current “Ident” and 
“Revision” of the application program.  This is accessed by the 
“View” menu, by selecting “Target Board Interface”. 
 

 
 
Once invoked, the set-up program will prompt the user to select a 
program to compare with the one existing in the processor.  Whether 
a program is selected or the user cancels, the setup program will 
attempt to communicate with the M4500.  If unsuccessful, a warning 
message will be displayed, prompting the user to either “Retry” or 
“Cancel” the operation.  If the operation is canceled and 
communication with the processor cannot be established the system 
will be placed in an “Offline” mode, however the “Target Board 
Interface” window will be displayed. 
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________________________________________________________ 
4.4.2 VIEW ONLINE DATA 
 
This function allows the user to place the set-up program in an 
“Online” mode with the processor.  This is accessed by the “View” 
menu, by selecting “Online Data” or by simply pressing the “F3” 
function key. 
 
Note:  The program can be toggled between “Offline” and “Online” 
by simply double clicking on the “Online” or “Offline” panel 
displayed in the status bar at the bottom of the window. 
 
Once invoked, the set-up program will attempt to open the Comm 
port and communicate with the M4500.  If the set-up program is 
unsuccessful, a warning message will be displayed prompting the user 
to either “Retry” or “Cancel” the operation.  If the operation is 
canceled and communication with the processor cannot be established 
the system will be placed in an “Offline” edit mode. 
 
Note:  Anytime while the set-up program is “Online” with the 
processor and communication is interrupted, a warning message will 
be displayed, prompting the user to either “Retry” or “Cancel” the 
operation. 
 
 
________________________________________________________ 
4.4.3 VIEW OFFLINE DATA 
 
This function allows the user to place the set-up program in an 
“Offline” mode.  This is accessed by the “View” menu, by selecting 
“Offline Data” or by simply pressing the “F4” function key.  This 
allows the user to perform “Offline” editing.  All values displayed in 
“Offline” edit mode reflect the actual values contained in the 
currently loaded set-up data file. 
 
Note:  The program can be toggled between “Online” and “Offline” 
by simply double clicking on the “Online” or “Offline” panel 
displayed in the status bar at the bottom of the window. 
 
Once invoked, the set-up program will close the Comm port and cease 
communication with the M4500. 
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________________________________________________________ 
4.5 THE WINDOW MENU 
 
The “Window” menu allows the user to select one of five different 
Display/Set-up windows to modify set-up parameters, view shift data 
or receive feedback about the current status of the control system. 
 

 
 
Once a window menu item is selected, a check mark is placed next to 
the selected item and the selected window is displayed with the name 
changed in the title bar of the main window. 
 
Note:  “Read” only variables are displayed in blue with a gray 
background.  Any variables that can be altered by the user are 
displayed in black with a white background.  In most cases, a 
parameter that can be changed by the user will have associated with it 
increment and decrement controls.  The user can either click on the 
desired parameter to adjust and enter in a new value, or use the 
increment or decrement controls to change the value by 1 unit. 
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________________________________________________________ 
4.5.1 THE MAIN DISPLAY WINDOW 
 
The “Main Display” window is used to display the general state of the 
control system.  This window is selected from the “Window” menu. 
 

 
 
The following is a list of the functions of the “Main Display” 
window. 
 
Messages:  The “Messages” display is continuously updated.  It 
displays alarm and status messages specific to the M4500, as well as, 
the current “Online” or “Offline” status of the set-up program. By 
simply scrolling the display, the user is able to view all active alarm 
and status messages.  If no alarm or status messages are active, a 
default message is displayed. 
 
Machine Speed SPM:  This display is only active while “Online” 
and displays the current speed of the machine in “Strokes Per 
Minute”. 
 
Machine Position:  This display is only active while “Online” and 
displays the current position to the main crank resolver in degrees.. 
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________________________________________________________ 
4.5.2 THE SETUP PARAMETERS WINDOW 
 
The “Set-up Parameters” window is used to view and adjust the set-
up parameters.  This window is selected from the “Window” menu. 
 

 
 
Canfeed Open/Initial Airstrip Strokes: 
 
Number of Strokes before Cupfeed Open:  This is the number 

of strokes (plus 2) that the machine will make with air strip, once 
the cupfeed is enabled, before it actually opens.  This allows 
coolant to be blown from the ram to prevent “Hydraulic Lock” 
(normally set to 2). 

 
Number of Cans Made with Initial Air Strip:  This is the 

number of cans made using the CH06 – “Initial Air Strip” timing 
channel when the cupfeed is first opened before switching to 
CH05 – “Normal Air Strip”.  This allows the first cans to made 
with more “Air Strip” while the tooling is cool. 

 



SECTION 4 
HSLWI5 SETUP PROGRAM  
REFERENCE 

 
HSL-WI5 User’s Manual SYSTEMS Electronics Group 

 
- 54 - 

Brake Wear Compensation: 
 
Brake Wear Compensation Enable:  This is used to enable or 

disable the brake wear compensation. If the compensation is to be 
disabled, click the checkbox to remove checked state. If the 
compensation is to be enabled, click the checkbox to set the 
checked state. 

 
Desired BDC Stop Position (Cont./Single):  This is the desired 

stopping location (in degrees) for a BDC stop when the brake 
wear compensation is enabled. This is typical set to 000 degrees 
(Back Dead Center). 

 
 Note:  This parameter is automatically disabled whenever “Brake 

Wear Compensation” is disabled. 
 
Maximum Allowed Stopping Response:  This defines what the 

maximum allowed brake response is before the “Brake Response 
Too Long” alarm is generated. If the actual brake response 
(number of degrees from when the brake is activated to the 
position where the press ends up at rest) when a BDC stop is 
performed is longer than this number, the alarm is generated. If 
the actual brake response is less, the alarm is not generated. Set 
this parameter to the value where the brake response is considered 
too long and service to the brake should be performed (typically 
270 to 300 degrees). 

 
Trimmer Speed References: 
 
Trimmer Maximum Speed (CPM):  The “Trimmer Maximum 

Speed” parameter is used to scale the 0-10VDC analog output 
such that when the bodymaker is running at the speed entered in 
“Trimmer Maximum Speed”, the analog output will be at 10 volts. 
This is typically set to the running high speed of the Bodymaker 
or slightly higher. 

 
Trimmer Idle Speed (CPM):  This parameter determines the speed 
the trimmer will run at when the bodymaker is stopped (de-clutched).  
 
Note:  When the bodymaker is running, the trimmer speed reference 
is proportional (as set by the “Trimmer Maximum Speed” scaling) to 
the speed of the bodymaker. This parameter is used to provide the 
speed reference when the bodymaker speed is zero. 
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Bodymaker Running Speeds: 
 
Running Bodymaker Low Speed (SPM):  This is the speed (in 

strokes per minute) the bodymaker will run when in low (inch) 
speed. 

 
Running Bodymaker High Speed (SPM):  This is the speed (in 

strokes per minute) the bodymaker will run when in high 
(cont./single) speed. 

 
 
________________________________________________________ 
4.5.3 THE MACHINE TIMING WINDOW 
 
The Machine Timing window is used to invoke the PLS programming 
command menus.  From this window, the user can view or adjust the 
following parameters: 
 
• Adjust Timing Channel set-points. 
• Set the Main Crank resolver offset. 
• Clear or Recall a PLS timing channel. 
• View the current PLS configuration 
• Reset the PLS configuration to default settings. 
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In addition, the following parameters are displayed at the bottom of 
this window: 
 
RPM:  This is the current speed in “Revolutions per Minute” of the 
main crank resolver. 
 
Position:  This is the current “Position” in degrees of the main crank 
resolver. 
 
Offset:  This is the current resolver offset (set in degrees). 
 
Scale:  This is the scale factor of the resolver or the number of 
divisions in one revolution. 
 
Note:  Section 5 – General Timing Signal Locations, provides a 
complete description of each timing channel signal. 
 
Zeroing Machine (set resolver offset):  To set machine zero, 
perform the following: 
 
1) From the “Window” menu, select “Machine Timing”. 
 
2) From the “View” menu, select “Online Data”.  The set-up 

program will attempt to communicate with the processor and 
place the system into an “Online” mode of operation. 

 
3) Observe the “Position” field at the bottom of the window.  Verify 

that as the machine is rotated forward, that the position increases 
linearly from 0 through 359 degrees.  If not, swap the S1 and S3 
leads at the resolver connector on the M4500.  Then, verify that 
the position does indeed increase with forward movement. 

 
4) Position the machine at back dead center. 
 
5) Auto zero the resolver by entering “0” in the “Resolver Offset” 

field and clicking the “Set Offset” command button.  A message 
box will appear, prompting the user to confirm their choice.  
Select “Yes” to set the resolver offset. 

 
6) The M4500 will calculate the actual offset value required to make 

this the “0” position.  The new offset value will be displayed in 
the “Offset” filed and the position will then read zero. 
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Adjusting the Timing Channel Set-points:  To set any of the 
timing signal set-points, perform the following: 
 
Note:  Any changes made to the timing channel set-points will be 
saved as part of the setup data file. 
 
1) From the “Window” menu, select “Machine Timing”. 
 
2) From the “View” menu, select “Online Data”.  The set-up 

program will attempt to communicate with the processor and 
place the system into an “Online” mode of operation. 

 
3) Set all channels per section 5 – General Timing Signal Locations.  

Set-points for a particular channel are either entered in the field or 
adjusted by using the increment/decrement controls. 

 
Note:  Only one set-point is used per channel.  

 
4) If a channel needs to be “Recalled” or “Cleared”, enter the desired 

channel number into the “PLS Channel” field.  Click the “Recall 
Channel” command button to recall the set-points.  Click the 
“Clear Channel” command button the completely clear all set-
points for the selected channel. 

  
Note:  If a channel has been cleared or the “On” and “Off” set-
points have the same setting, the set-point will be displayed as 
“*****”. 

 
Resetting the PLS Configuration:  As an aid to the user the 
current PLS configuration is displayed as part of this window.  The 
PLS configuration should only need to be reset if a new module has 
been installed.  To reset the PLS configuration, click the “Reset PLS 
Config” command button.  This function only resets the PLS 
configuration to the default settings for the bodymaker. 
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________________________________________________________ 
4.5.4 THE SHIFT DATA WINDOW 
 
This window is used to view the Current Shift data, Last Shift data, 
Low and High speed brake responses and to invoke the “End of Shift” 
data transfer. 
 

 
  
Note:  Prior to selecting this selection, make sure an RS-232 SYSdev 
cable is connected from the COM port on the computer to the PROG 
port on the M4500. The following data is displayed in this window: 
 
Current Shift - Total Good Cans: This is the total number of 
good cans produced so far into the current shift. This is essentially a 
can counter. 
 
Current Shift - Total Short Can Faults: This is the total number 
of short can faults that have occurred so far into the current shift. 
 
Last Shift - Total Good Cans: This is the total number of good 
cans produced in the last (previous) shift. This is essentially a can 
counter. 
 
Last Shift - Total Short Can Faults: This is the total number of 
short can faults that occurred in the last (previous) shift. 
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Note: The current shift data is transferred to the “Last shift” data 
when the end of shift input transfers from a “0” to a “1”. This can be 
at the end of either an 8 or 12-hour shift. This data can also be reset 
from this menu by clicking the “Transfer Data” command button. 
 
Lo Speed Brake Response (degrees): This is the number of 
degrees from the when the clutch was de-activated (at the BDC (Lo) 
timing) to where the bodymaker crankshaft came to rest when a BDC 
stop was performed at Low speed. This can be used to determine the 
general condition of the brake and whether servicing of the brake is 
required. 
 
Hi Speed Brake Response (degrees): This is the number of 
degrees from the when the clutch was de-activated (at the BDC (hi) 
timing) to where the bodymaker crankshaft came to rest when a BDC 
stop was performed at high speed. This can be used to determine the 
general condition of the brake and whether servicing of the brake is 
required. 
 
Note:  The brake response for both high and low speeds is updated 
after each BDC stop. 
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________________________________________________________ 
4.5.5 THE I/O STATES WINDOW 
 
The “I/O States” window is provided to display states of the inputs 
and outputs.  The control boards, the states of the timing channels, as 
well as states of the M4500 are shown.  This includes the interrupt 
inputs (IN0 and IN1), the analog I/O and the resolver.  These values 
are displayed as read by the M4500 processor. 
 

 
 
 
 


