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The Windows based set-up program is menu driven, allowing the user to easily view data, alter set-
up variables or set machine timing (machine offset, timing signal locations, etc.), using a PC 
running the Windows (95/98/ME/2000/XP/NT) operating system. The set-up variables are used to 
configure and tune the M4530 to match the configuration and performance of the specific tester (see 
Tuning the HSL-RT6-M45, section 2.12). 
 
Note:  The set-up program is an on-line communications program used to interface with the M4530 
module.  The data displayed and set in the windows is communicated directly to the module, while 
in the “Online” edit mode. Therefore, prior to going online with the processor, make sure an RS-
232 cable is connected from the COM port on the computer to the “PROG” port on the M4530.  
The variables displayed while in the “Online” edit mode are read directly from the processor.  Data 
is saved to a “Set-up Data” file (*.sdt) whenever changes are made to a parameter or if the data is 
uploaded from the processor. 
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________________________________________________________________________________ 
5.1 GENERAL DESCRIPTION 
 
Title Bar:  At the top of the window is the “Title Bar”.  The title bar is used to display the name of 
the working “Set-up Data” file, as well as, the name of the active “Window”.  The title bar is dark if 
the window is active and grayed if another window is active.  The color depends on the settings of 
the Display Properties of the Control Panel. 
 
Status Bar:  At the bottom of the window is the “Status Bar”.  The status bar is used to display 
system messages, online or offline mode, as well as, the current time and date as set by the 
operating system.  The system messages panel displays general information about operation of the 
system.  The Online/Offline mode panel displays the status of the current set-up program mode of 
operation.  The mode of operation can be changed by simply double clicking the online/offline 
mode panel. 
 
Hot Keys:  Hot keys are activated by holding down the “ALT” key and simultaneously pressing 
the underlined letter of the desired function.  Almost every function can be activated by either 
pressing a series of hot keys or using the “TAB” key to move between fields. 
 
Online/Offline Modes:  The set-up program allows the user to make changes while “Online” 
with the processor.  The “Offline” mode is used to preset parameters prior to download.  All 
functions are available to the user while “Online”, however, specific “Online” functions are 
disabled in the “Offline” edit mode. 
 
Note:  Offline changes can only be made by enabling “Offline Editing”, accessed under the “Edit” 
menu. 
 
Getting Help:  The entire contents of the user’s manual is contained within the help file.  Pressing 
Ctrl+H will display the help file window.  Pressing the F1 key will display the contents file.  Hot 
spots allow jumps to other topics to display additional information as desired.  Selecting About 
HSLRT6 from the Help menu will display a dialog box listing information about the current 
revision of the setup program and how to obtain technical support. 
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________________________________________________________________________________ 
5.2 THE FILE MENU 
 
The “File” menu allows the user to perform the following functions: 
 
• Create a “New” set-up “Data File”. 
• Open an existing “Data File”. 
• Save any changes made to the current “Data File” to disk. 
• Upload (save) Data from the Processor. 
• Download a SYSdev (.sdv) program to the processor 
• Download (restore) Data from the current set-up “Data File” to the processor 
• Print a Report of the current set-up parameters. 
• Exit the set-up program 
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________________________________________________________________________________ 
5.2.1 THE SET-UP DATA FILE 
 
The set-up “Data File” (.sdt) is a binary access file, designed for fast file I/O operation.  When the 
set-up program is first invoked, the default set-up parameters are loaded into memory.  If changes 
are made to any of the set-up parameters (either online or offline), as well as shift data, the user will 
be flagged to “Save Changes” upon exit of the program. 
 
Note:  Any windows based “Set-up” program can open a set-up “Data File”, however, the data 
tables will not be properly aligned.  The user will be alerted to the problem if a set-up data file has 
been created by either a different set-up program or a different revision of the software. 
 
The set-up “Data File” is similar to that of a word processing file.  When the program first starts, 
the default parameters are loaded and the user is able to make changes as desired.  The set-up 
program is unaware of the settings and parameters that exist within the M4530.  Therefore, to 
normalize the set-up program with the processor, the user should define or open an existing file, 
then upload “All” variables from the processor.  This allows the user to either create a backup of the 
data or maintain an existing file.  The user can even open a data file for another tester, save the file 
to a new name, make the necessary changes and simply download the new parameters to another 
processor. 
 
The following functions can be accessed any time, from any set-up or display windows. 
New:  To create a “New” data file, select “New” from the “File” menu or press “Ctrl + N”.  This 
creates a completely new file, loaded with the default variables and the word “[unnamed]” is 
displayed in the title bar.  If any changes were made to the existing file, the user is prompted to save 
changes to the existing file. 
 
Open:  To “Open” an existing data file, select “Open” from the “File” menu or press “Ctrl + O”.  
This displays a dialog box allowing the user to select an existing data file. The name of the file will 
then be displayed in the title bar.  If any changes are made to the parameters (including shift data), 
the user will be prompted to save any changes before terminating the program. 
 
Save:  To “Save” the data to disk, select “Save” from the “File” menu or press “Ctrl + S”.  This 
displays a dialog box allowing the user to select a folder and enter a name for the file.  The user will 
be notified if the file exists. The extension “.sdt” will automatically be added to the file name.  If 
this is a “New” file, the user will be prompted to enter a file name. 
 
Save As:  To save the data file to a new name, select “Save As” from the “File” menu..  This 
displays a dialog box allowing the user to select a folder and enter in a new name for the file.  The 
user will be notified if the file exists and the extension “.sdt” will automatically be added to the file 
name. 
 
Export Shift Data…:  This function allows the user to export the shift data to a “Tab Delimited” 
text file.  This allows the user to easily use the shift data to produce production reports. 
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________________________________________________________________________________ 
5.2.2 UPLOAD (SAVE) DATA 
 
The “Set-up” program allows the user to upload set-up parameters, timing channel set-points and 
shift data from the M4530 into a set-up “Data File”.  This function is accessed from the “File” menu 
and the user is given the choice of the following options: 
 

 
 
 
M4530 PROG Port:  This option allows the user to upload set-up parameters, timing channel set-
points and shift data from the M4530. If not connected to the M4530 PROG port, a message will be 
displayed alerting the user. 
 
S4030 CAL Port:  This option allows the user to upload PMT set-up parameters and data from the 
S4030 PMT processor board. If not connected to the S4030 CAL port, a message will be displayed 
alerting the user. 
 



SECTION 5 
HSLRT6 WINDOWS BASED 
SETUP PROGRAM REFERENCE 

 
HSL-RT6-M45 User’s Manual SYSTEMS Electronics Group 

 
- 42 - 

________________________________________________________________________________ 
5.2.3 DOWNLOAD PROGRAM 
 
The “Set-up” program allows the user to “Download” the HSLRT6 SYSdev program to the M4530. 
 

 
 
Note:  To “Download” a SYSdev program to the processor, the program must be “Online”.  If 
“Online” mode cannot be achieved, program download will not be executed.  If the program is 
currently “Offline”, the user will be prompted to first go “Online”. 
 
Once selected, and “Online” with the processor, a dialog box will be displayed, allowing the user to 
select the SYSdev file to download. 
 
Note:  Only the files with the “.sdv” file extension will be displayed.  It is important to keep in 
mind that only a valid M4530 PLC SYSdev file can be downloaded with the set-up program.  Care 
should be taken when selecting a program to download. 
 
If not connected to the M4530 PROG port, a message will be displayed alerting the user.  
 
Once selected, a message box is displayed informing the user of the current program, revision and 
checksum of the program loaded in the processor, as well as, that of the selected program.  The user 
must confirm their selection by clicking the “Yes” command button.  After the user confirms their 
choice, program download is initiated and the current program download address is displayed.  
When program download is complete, the user is prompted to acknowledge.  Control is passed back 
to the main program and the set-up program remains in an “Online” edit mode. 
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________________________________________________________________________________ 
5.2.4 DOWNLOAD (RESTORE) DATA 
 
The set-up program allows the user to download  “Set-up” parameters, timing channel set-points 
and shift data to the M4530 and S4030 from the set-up “Data File”.  This function is accessed from 
the “File” menu and the user is given the choice of the following options: 
 

 
 
M4530 PROG Port:  This option allows the user to download the set-up parameters, timing 
channel set-points and shift data to the M4530.  If not connected to the M4530 PROG port, a 
message will be displayed alerting the user. 
 
S4030 CAL Port:  This option allows the user to download the PMT set-up parameters to the 
S4030 PMT Processor board.  If not connected to the M4530 PROG port, a message will be 
displayed alerting the user. 
 
Note:  Only the values contained within the current data file are used.  If the validity of the current 
data file is questionable, review the data in an “Offline” mode prior to download. 
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________________________________________________________________________________ 
5.2.5 PRINT REPORT 
 
The “Set-up” program allows the user to generate a “Report” printout of all the set-up parameters, 
timing channel set-points and shift data.  This function is accessed from the “File” menu. 
 
At the top of each page, the report displays the name of the set-up file being printed.  At the bottom 
of each page is the date and time the document was printed, as well as, the page number. 
 
To printout a report of the settings contained in the set-up “Data File”, perform the following: 
 
1) From the “File” menu, select “Print Report” or press “Ctrl + P”.  This displays the “Print Setup” 

dialog box, allowing the user to select a printer, as well as, the paper size and orientation.  Once 
the user selects “OK”, the report is generated and sent to the specified printer device.  This 
function makes use of the windows print manager, which allows the user to continue with their 
work while the document is being printed. 

 
 
________________________________________________________________________________ 
5.3 THE EDIT MENU 
 
The “Edit” menu allows the user to perform the following functions: 
 
• Enable/Disable Offline Editing. 
• Set-up the Comm Port. 
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________________________________________________________________________________ 
5.3.1 ENABLE OFFLINE EDITING 
 
This function allows the user to perform “Offline” editing on the currently loaded set-up data file.  
This allows the user the ability to make any necessary changes to the set-up parameters while not 
online with the processor.   
 
If offline editing is not enabled, the user is only able to view the set-up parameters and shift data.  
When the program is first invoked, the default setting is offline editing disabled.  The user will need 
to select “Enable Offline Editing” from the edit menu (or press function key F2) to enable/disable 
this feature. 
 
 
________________________________________________________________________________ 
5.3.2 SETUP COMM PORT 
 
This function allows the user to specify the serial communications port and rate to talk to the 
M4530.  The programming port of the M4530 is set to 9600 baud.   
 

 
 
Once selected, a dialog box requesting the user to select a “Comm Port” and “Baud Rate” will be 
displayed.  The default setting is COM1 at 9600 baud.  The option to select the 19200 baud rate is 
to allow the user to communicate with the processor via the S4516 serial communications board. 
 
In most cases, the user will only need to specify the communications port and leave the baud rate at 
9600.  If communication problems occur, make sure there is a secure connection from the PC to the 
PLC.  Then check the Comm port.  In most cases, the user will only need to select a new Comm 
port.  If communication problems persist, there may be another program causing a conflict with the 
port.  Check the port configuration from the Windows “Settings” folder. 
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________________________________________________________________________________ 
5.4 THE VIEW MENU 
 
The “View” menu allows the user to perform the following functions: 
 
• View the “Target Board Interface” 
• View “Online” Data 
• View “Offline” Data 
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________________________________________________________________________________ 
5.4.1 TARGET BOARD INTERFACE 
 
This function allows the user to view fault codes, S3000 network communication error codes and 
review the current “Ident” and “Revision” of the application program.  This is accessed by the 
“View” menu, by selecting “Target Board Interface”. 
 

 
 
Once invoked, the set-up program will prompt the user to select a program to compare with the one 
existing in the processor.  Whether a program is selected or the user cancels, the setup program will 
attempt to communicate with the M4530.  If unsuccessful, a warning message will be displayed, 
prompting the user to either “Retry” or “Cancel” the operation.  If the operation is canceled and 
communication with the processor cannot be established the system will be placed in an “Offline” 
mode, however the “Target Board Interface” window will be displayed. 
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________________________________________________________________________________ 
5.4.2 VIEW ONLINE DATA 
 
This function allows the user to place the set-up program in an “Online” mode with the processor.  
This is accessed by the “View” menu, by selecting “Online Data” or by simply pressing the “F3” 
function key. 
 
Note:  The program can be toggled between “Offline” and “Online” by simply double clicking on 
the “Online” or “Offline” panel displayed in the status bar at the bottom of the window. 
 
Once invoked, the set-up program will attempt to open the Comm port and communicate with the 
M4530.  If the set-up program is unsuccessful, a warning message will be displayed prompting the 
user to either “Retry” or “Cancel” the operation.  If the operation is canceled and communication 
with the processor cannot be established the system will be placed in an “Offline” edit mode. 
 
Note:  Anytime while the set-up program is “Online” with the processor and communication is 
interrupted, a warning message will be displayed, prompting the user to either “Retry” or “Cancel” 
the operation. 
 
 
________________________________________________________________________________ 
5.4.3 VIEW OFFLINE DATA 
 
This function allows the user to place the set-up program in an “Offline” mode.  This is accessed by 
the “View” menu, by selecting “Offline Data” or by simply pressing the “F4” function key.  This 
allows the user to perform “Offline” editing.  All values displayed in “Offline” edit mode reflect the 
actual values contained in the currently loaded set-up data file. 
 
Note:  The program can be toggled between “Online” and “Offline” by simply double clicking on 
the “Online” or “Offline” panel displayed in the status bar at the bottom of the window. 
 
Once invoked, the set-up program will close the Comm port and cease communication with the 
M4530. 
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________________________________________________________________________________ 
5.5 THE WINDOW MENU 
 
The “Window” menu allows the user to select one of five different Display/Set-up windows to 
modify set-up parameters, view shift data or receive feedback about the current status of the control 
system. 
 

 
 
Once a window menu item is selected, a check mark is placed next to the selected item and the 
selected window is displayed with the name changed in the title bar of the main window. 
 
Note:  “Read” only variables are displayed in blue with a gray background.  Any variables that can 
be altered by the user are displayed in black with a white background.  In most cases, a parameter 
that can be changed by the user will have associated with it increment and decrement controls.  The 
user can either click on the desired parameter to adjust and enter in a new value, or use the 
increment or decrement controls to change the value by 1 unit. 
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________________________________________________________________________________ 
5.5.1 THE MAIN DISPLAY WINDOW 
 
The “Main Display” window is used to display the general state of the control system.  This 
window is selected from the “Window” menu. 
 

 
 
The following is a list of the functions of the “Main Display” window. 
 
Messages:  The “Messages” display is continuously updated.  It displays alarm and status 
messages specific to the M4530, as well as, the current “Online” or “Offline” status of the set-up 
program  By simply scrolling the display, the user is able to view all active alarm and status 
messages.  If no alarm or status messages are active, a default message is displayed. 
 
Machine CPM:  This display is only active while “Online” and displays the current speed of the 
tester in “Cans Per Minute”. 
 
Good Cans:  This display is the “Current Shift” good can count.   
 
Rejects:  This display is the “Current Shift” total reject count. 
 
PMT Applied Gain (Volts): This is the voltage applied to the tube. The value is set in 5-volt 
increments, between 498 and 1200. This parameter is adjusted when the PMT Gain calibration is 
performed. It can also be adjusted manually using the up/down increment control. Adjusting this 
value adjusts the gain of the tube. 
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Adjusting the PMT Gain:  This selection is used to manually increase or decrease the PMT 
Gain. Once online with the M4530 through the PROG port, this control is active.  The up/down 
increment control can be used to adjust the gain by 5 volts each time the corresponding key is 
depressed. Increasing the gain will increase the sensitivity of the system, decreasing the gain will 
decrease the sensitivity of the system.  
 
PMT Offset: This is the input offset value (between -250 and +250) and adjusts the M4530 input 
offset proportionally. This parameter is adjusted automatically in response to variations of the PMT 
offset (see section 3.1 – Automatic Offset Adjustment). 
 
Threshold: This value specifies the reject threshold. If the “PMT Input” value is below this 
threshold, the can is considered good and is not rejected. If the “PMT Input” value is above this 
threshold, the can is considered a leaker and is rejected. Typically, this parameter is set between 35 
and 75. This parameter is adjusted using the up/down increment control 
 
Adjusting the Threshold:  This selection is used to increase or decrease the Reject Threshold. 
Once online with the M4530 through the PORG port this control is active.  The up/down control 
can be used to adjust the threshold by one each time the corresponding key is depressed. Increasing 
the threshold will decrease the sensitivity of the system, decreasing the threshold will increase the 
sensitivity of the system.  
 
PMT Average: This is the average of all good cans and the in-between pocket “dark” 
measurements for 36 consecutive cans. 
 
Calibrate PMT:  This selection is used to execute the PMT Gain calibration procedure. If the 
calibration is to be performed, stop the tester, align a calibrated leak test can at the PMT and select 
the “Calibrate PMT” button.  
 
If the button is pressed, the calibration will be performed (see section 3.3 – Automatic Gain 
Adjustment, Calibration). Once the calibration is initiated, the message display will show  “PMT 
Gain Calibration In Progress”.  The applied PMT gain will display the current gain in volts. If the 
calibration is not successful, the message display will show “Calibration Error”. See section 3.4 – 
Calibration Procedure, for details on the calibration error. 
 
Note: This function is only available while online with the processor through the PROG port and 
the tester is stopped. 
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________________________________________________________________________________ 
5.5.2 THE MACHINE TIMING WINDOW 
 
The Machine Timing window is used to invoke the PLS programming command menus.  From this 
window, the user can view or adjust the following parameters: 
 
• Adjust Timing Channel setpoints. 
• Set the resolver offset. 
• Clear or Recall a PLS timing channel. 
• View the current PLS configuration 
• Reset the PLS configuration to default settings. 
 

 
 
In addition, the following parameters are displayed at the bottom of this window: 
 
RPM:  This is the current speed in “Revolutions per Minute” of the main crank resolver. 
 
Position:  This is the current “Position” in degrees of the main crank resolver. 
 
Offset:  This is the current resolver offset (set in degrees). 
 
Scale:  This is the scale factor of the resolver or the number of divisions in one revolution. 
 
Note:  The General Timing Signal Locations section provides a complete description of each 
timing channel signal. 



SECTION 5 
HSLRT6 WINDOWS BASED 

SETUP PROGRAM REFERENCE 

 
HSL-RT6-M45 User’s Manual SYSTEMS Electronics Group 

 
- 53 - 

Zeroing the Machine (setting the resolver offset):  To set the machine zero (resolver offset) 
perform the following: 

 
1) Connect the RS-232 cable from the COM port on the computer to the “PROG” port on the 

M4530 and go online with the processor. 
 
2) From the “View” menu, select “Online Data”.  The set-up program will attempt to communicate 

with the processor and place the system into an “Online” mode of operation. 
 
3) Observe the “POS:” field. Verify that as the machine is rotated forward that the position 

increases linearly from 0 through 359. If not, swap the S1 and S3 leads of the resolver at the 
M4530 resolver connector. Then verify that the position then indeed does increase with forward 
movement.  

 
4) Position the machine with pocket #1 perfectly aligned with the PMT. This is the machine zero 

position. 
 
5) Auto zero the resolver by entering “0” in the offset field and then “Click” the “Set Offset” 

button. 
 
6) The M4530 will calculate the actual offset value required to make this the 000 position and will 

display this number in the offset field. The position will now read 0. 
 
 Note:  The offset can only be changed while online with the processor with the machine 

stopped. 
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Adjusting the Timing Channel Setpoints:  To set any of the timing signal setpoints, perform 
the following: 
 
Note:  Any changes made to the timing channel setpoints will be saved as part of the setup data 
file. 
 
1) Connect an RS-232 SYSdev cable from the COM port on the computer to the “PROG” port on 

the M4530.   
 
2) From the “Window” menu, select “Machine Timing”. 
 
3) From the “View” menu, select “Online Data”.  The set-up program will attempt to communicate 

with the processor and place the system into an “Online” mode of operation. 
 
4) Set-points are entered for a particular channel simply by typing in the set-point. 
 
 Note: CH00 (Sync timing) and CH01 (Marker timing) are automatically programmed at power-

up and should not be modified by the user. Only CH02 thru CH07 can be programmed by the 
user if additional timing signals are required by the user (these channels are not used by the 
HSLRT6 program).  Only one set-point is can be programmed per channel.  

 
5) If a channel needs to be “Recalled” or “Cleared”, enter the desired channel number into the 

“PLS Channel” field.  Click the “Recall Channel” command button to recall the setpoints.  Click 
the “Clear Channel” command button the completely clear all setpoints for the selected channel. 

  
 Note:  If a channel has been cleared or the “On” and “Off” setpoints have the same setting, the 

set-point will be displayed as “*****”. 
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Resetting the PLS Configuration:  As an aid to the user the current PLS configuration is 
displayed in the “PLS Configuration” tab of this window.  The PLS configuration should only be 
reset if a new module has been installed.  To reset the PLS configuration, click the “Reset PLS 
Config” command button.  This function only resets the PLS configuration to the default settings. 
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________________________________________________________________________________ 
5.5.3 THE SERIAL COMMUNICATIONS WINDOW 
 
The Serial Communications window is used to view the configuration status of the S4516 serial 
communications board (if installed), as well as, view the status of the Allen-Bradley DF1 
communication protocol and set-up the Allen-Bradley PLC communication parameters.  From this 
window the user can view or adjust the following parameters: 
 
• View the S4516 configuration status. 
• View the S4516-DF1 serial communication status. 
• View the Allen-Bradley Link Layer serial communication status. 
• Select the Allen-Bradley PLC type (PLC5 or SLC500) to communicate to. 
• View/Set the Allen-Bradley PLC destination node. 
• Select the starting Allen-Bradley PLC destination file number. 
 

 
 
S4516 Configuration Status:  This displays the current state of the configuration of the S4516 
serial communications board.  System function sfunc19(); (S4516 configuration) is used to set the 
S4516 configuration (network node address, network baud rate and USER port baud rate).  This 
must be executed prior to executing ether system functions 10, 11 or 13.  System function 19 is 
generally executed in the “Initialization” file of the user program. 
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The following values are returned from a system function 19 call: 
 1 = Busy. 
 2 = Done (S4516 Successfully configured). 
 3 = Invalid Parameter (either network node address, network baud rate or USER port baud 

rate is invalid). 
 4 = Timeout (no response form S4516) 
 32 = Hardware ACK error from S4516 
 34 = Invalid S4516 Slot Address (W8156 must be loaded with the slot address of the S4516, 

prior to executing system function 19). 
 
Transmit Data Status:  This represents the state of the data packet transmission. This will 
typically display either “Busy” or “Done”.  If there are problems delivering the message packet, the 
response code, along with a description, will be displayed. 
 
Note:  The “Transmit Data Status (prev.)” is used to view the last or previous status. 
 
Current Transaction:  This is the “Transaction” number delivered to the Allen-Bradley PLC. 
 
Active Command:  This displays either “Read” or “Write”.  This is used to view the command 
type of the current transaction. 
 
Number of  BYTES Received:  This displays the current number of bytes received from either a 
“Command” or “Reply” message packet. 
 
Received Command BIT Status:  This displays the state of the command received.  If this 
displays a “Reply”, then the command was sent from the M4530.  If this displays “Command”, then 
a command action was received by the M4530. 
 
A/B Link Layer Status:  This displays the status of the receipt of the message packet sent to the 
Allen-Bradley PLC.  If the delivery is not successful, an error code along with a description is 
displayed.  Refer the to the Allen-Bradley Communication Protocol and Command Set reference 
manual for more information on “Link Layer” error codes. 
 
A/B Link Layer – Current Transaction Received:  This is the “Transaction” number received 
from the Allen-Bradley PLC. 
 
PLC Type:  This is used to specify the “Type” of PLC the M4530 will communicate to.  The user 
can choose from “PLC5” or “SLC500”. 
 
Note:  This parameter should be set prior to communicating with an A/B processor. 
 
Destination Node:  This is used to set the node number of the A/B PLC to send and receive data 
from.  This also displays the node number of the A/B PLC that send a “Command” message packet. 
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Destination File Number:  This is the file number the M4530 will read and write data from.  See 
Appendix B for a description of the data read from and written to an Allen-Bradley PLC. 
 
 
________________________________________________________________________________ 
5.5.4 THE SHIFT DATA WINDOW 
 
The “Shift Data” window is used to view the shift data collected by the M4530.  This window is 
selected from the “Window” menu. 
 

 
 
This window utilizes a “TAB” control to divide the set-up parameters into three categories, similar 
to that of the Keypad/Display.  These sections are as follows: 
 
Rejects Per Pocket: The number of rejects per pocket menu is provided to aid in the trouble-
shooting of a bad seal with a particular pocket. The total number of rejects for each pocket since the 
last reset or end of shift is displayed. The user can reset these counts at any time to aid in the 
trouble-shooting process. 
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Current Shift Data:  This section is used to view the “Current Shift” data.  This data is the totals 
so far into the shift.  This data is transferred to the “Last shift” at the end of either an 8 or 12 hour.  
This data can be reset by the user from this section. 
 

 
 
Note:  The “Transfer Data” command button is only active while “Online”.   
 
The Current shift data menu displays the following information: 
 
1) Total Good Cans Processed: 
 
2) Total Rejected Cans (for all pockets): 
 
 Number of Rejected Cans (for each pocket): 
 Pocket #1: 
     thru 
 Pocket #12: 
 
This data is the totals so far into the shift. This data is transferred to the “Last shift” data when the 
end of shift input transfers from a “0” to a “1”. This can be at the end of either an 8 or 12 hour shift 
or alternatively could be done at label changes such that the data collected would be for label runs 
rather than complete shifts. 
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Last Shift Data:  The “Last Shift” data is identical to the current shift data except it is for the 
previous 8 or 12 hour shift or previous label run, however the shift collection is set-up.  This allows 
data collection and diagnostics to take place automatically over a two shift period. 
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________________________________________________________________________________ 
5.5.5 THE I/O STATES WINDOW 
 
The “I/O States” window is provided to display states of the inputs and outputs.  The control 
boards, the states of the timing channels, as well as states of the M4530 are shown.  This includes 
the interrupt inputs (IN0 and IN1), the analog I/O and the resolver.  These values are displayed as 
read by the M4530 processor. 
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________________________________________________________________________________ 
5.6 THE PMT WINDOW 
 
The “PMT” window is used to view and adjust any of the PMT setup parameters. 
 

 
 
Note: Prior to selecting PMT window, make sure the RS-232 cable is connected from the COM1 
port on the computer to the CAL PORT on the M4530. 
 
This window utilizes a “TAB” control to divide the set-up parameters into two categories.  These 
sections are as follows: 
 
PMT Setup Parameters:   
1) Automatic Offset Mode Enabled: When “Checked”, the automatic offset mode is enabled 

(see section 3.1 – Automatic Offset Adjustment). When “Unchecked”, the manual offset mode 
is enabled (see section 3.2 – Manual Offset Adjustment). 

 
2) PMT Input Offset (-250 to 250): This is the input offset value and adjusts the M4530 input 

offset proportionally. This parameter is set by the user in manual offset mode or is adjusted 
automatically when in the automatic offset mode. 

 
3) Desired Good Can PMT Value: Used in the automatic offset mode. This value is set by the 

user to specify the desired good can average. The M4530 adjusts the input offset until the 
average good can input is within the specified error (see section 3.1 – Automatic Offset 
Adjustment). 
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4) Allowed Good Can Error: This parameter is used in conjunction with the "Desired Good 
Can PMT Value" to adjust the PMT input offset in the automatic offset mode. The M4530 will 
adjust the offset until the good can average is within the value entered in "Allowed Good Can 
Error" of the "Desired Good Can PMT Value". 

 
5) PMT Gain Calibration Mode Enabled: When “Checked”, the “Automatic Gain 

Calibration” mode is enabled (see section 3.3 – Automatic Gain Adjustment).  When 
“Unchecked”, the “Manual Gain” mode is enabled (see section 3.5 – Manual Gain Adjustment). 

  
6) Gain Calibrate PMT Input Average: This is the average PMT input value of the last 6 

samples taken while a calibration cycle is in process. The M4530 compares this value to the 
"Desired Calibrated Leaker Reject PMT Value" and adjusts the PMT gain accordingly while a 
calibrate cycle is in progress (see section 3.4 – Calibration Procedure). 

 
7) Desired Calibrated Leaker Reject PMT Value: Used in the auto gain mode. This value is 

set by the user to specify the desired reject average. The M4530 adjusts the PMT gain until the 
average calibrate value is within the specified error. 

 
8) Allowed Calibrated Leaker Reject Error: This parameter is used in conjunction with the 

"Desired Calibrated Leaker Reject PMT Value" to adjust the PMT gain in the auto gain mode. 
The M4530 will adjust the gain until the calibrate average is within the value entered in 
"Allowed Calibrated Leaker Reject Error" of the Desired Calibrated Leaker Reject PMT Value" 
(see section 3.3 – Automatic Gain Adjustment). 

 
9) PMT Reject Can Threshold: This value specifies the reject threshold. If the "PMT Input" 

value is below this threshold, the can is considered good and is not rejected. If the "PMT Input" 
value is above this threshold, the can is considered a leaker and is rejected. Typically this 
parameter is set between 35 and 75. 

 
10) PMT Gain (PMT Voltage 0-1200V): Adjusting this value adjusts the voltage applied to the 

tube, thus adjusting the gain of the tube. The value is set in 5 volt increments, thus when a 
number is entered, it will be rounded to the nearest 5 volt increment. This parameter is set by 
the user in manual gain mode (see section 3.5 – Manual Gain Adjustment) or is adjusted 
automatically when calibration is performed in the auto gain mode (see section 3.3 – Automatic 
Gain Adjustment). 

 
11) M4530 PMT Input Sensitivity: This is a value, from 0 to 7, which adjusts how much the 

output from the PMT (input to the M4530) is amplified internally in the M4530. The higher the 
number, the higher the M4530 sensitivity will be. In general, this is set at the highest 
amplification and is only lowered if the PMT is too sensitive.
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View PMT Data:  The “View PMT Data” selection is used to view the good can and reject 
data in real time as well as manually fine tune the PMT gain. 

 

 
 
1) PMT Gain: This value adjusts the voltage applied to the tube, thus adjusting the gain of the 

tube. The value is set in 5 volt increments, thus when a number is entered, it will be rounded to 
the nearest 5 volt increment. This parameter is set by the user in manual gain mode or adjusted 
automatically when a calibration is preformed in the auto gain mode or is incremented or 
decremented by 5 from this menu. 

 
2) PMT Offset: This is the input offset value and adjusts the M4530 input offset proportionally. 

This parameter is set by the user in manual offset mode or is adjusted automatically when in the 
automatic offset mode. 

 
3) PMT Input: This is the value (0 to 255) of the last PMT sample and is proportional to the 

amount of light detected by the PMT where 0 equals no light detected and 255 equals maximum 
light detected. 

 
4) PMT Input Average: This is the average of all good cans and the in-between pocket "dark" 

measurements for 36 consecutive cans. 
 
5) PMT Up Deviation: This is the average up deviation from the good can "PMT Input Average" 

for 36 consecutive cans. The lower the number, the less deviation between all good cans, the 
higher the number, the more deviation. 
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6) PMT Down Deviation: This is the average down deviation from the good can "PMT Input 
Average" for 36 consecutive cans. The lower the number, the less deviation between all good 
cans, the higher the number, the more deviation. 

 
7) Up Deviation Count: This is the number of good cans that deviated up from the good can 

"PMT Input Average" in the last 36 consecutive pockets. 
 
8) Down Deviation Count: This is the number of good cans that deviated down from the good 

can "PMT Input Average" in the last 36 consecutive pockets. 
 
9) Up Peak (Max): This is the highest PMT input value detected as a good can in the last 36 

consecutive pockets. 
 
10) Down Peak (Min): This is the lowest PMT input value detected as a good can in the last 36 

consecutive pockets. 
 
11) Average Reject Value: This is the average value of the PMT input for the last 8 rejects. 
 
12) # of Rejects (of Last 36 cans): This is the number of leakers (rejects) detected in the last 36 

consecutive pockets. 
 
13) Last Reject Value through 8th to Last Reject Value: These 8 variables are a stack that 

contain the values of the last 8 rejects. 


